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SAFETY INFORMATION

This manual provides general and specific maintenance procedures essential for reliable engine operation
and your safety. Since many variations in procedures, tools, and service parts are involved, advice for all
possible safety conditions and hazards cannot be stated.

Read safety instructions before doing any service and test procedures for the engine or vehicle. See related
application manuals for more information.

Obey Safety Instructions, Warnings, Cautions, and Notes in this manual. Not following Warnings, Cautions,
and Notes can lead to injury, death, or damage to the engine or vehicle.

Safety Terminology

Terms are used to stress your safety and safe operation of the engine: Warning, Caution, and Note

Warning: A warning describes actions necessary to prevent or eliminate conditions, hazards, and unsafe
practices that can cause personal injury.

Caution: A caution describes actions necessary to prevent or eliminate conditions that can cause damage to
the engine or vehicle.

Note: A note describes actions necessary for correct, efficient operation.

Work Area

» Keep work area clean, dry, and organized.

» Keep tools and parts off the floor.

* Make sure the work area is ventilated and well lit.

¢« Make sure a First Aid Kit is available.

Protective Measures

»  Wear protective safety glasses and shoes.

*  Wear correct hearing protection.

*  Wear cotton work clothing.

*  Wear sleeved, heat protective gloves.

* Do not wear rings, watches, or other jewelry.

* Restrain long hair.

Vehicle

»  Shift transmission to neutral, set parking brake, and block wheels before doing diagnostic or service
procedures.

» Clear the area before starting the engine.




Safety Equipment
* Use correct lifting devices.

¢« Use wheel chocks and stands.

Engine

* The engine should be operated or serviced only by qualified individuals.

* Provide necessary ventilation when operating engine in a closed area.

» Keep combustible material away from engine exhaust system and exhaust manifolds.
» Install all shields, guards, and access covers before operating engine.

» Do not run engine with unprotected air inlets or exhaust openings. If unavoidable for service reasons, put
protective screens over all openings before servicing engine.

»  Shut engine off and relieve all pressure in the system before removing panels, housing covers, and caps.

» If an engine is not safe to operate, tag the engine and ignition key.

Fire Prevention
* Make sure charged fire extinguishers are in the work area.
NOTE - Check the classification of each fire extinguisher to make sure that the following fire types can
be extinguished:
1. Type A — Wood, paper, textiles, and rubbish
2. Type B — Flammabile liquids
3. Type C — Electrical equipment

Batteries

» Always disconnect the main negative battery cable first.
« Always connect the main negative battery cable last.

* Avoid leaning over batteries.

*  Protect your eyes.

* Do not expose batteries to flames or sparks.

* Do not smoke in workplace.
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INTRODUCTION

Figure 1 Diamond Logic Builder

In 2001, Navistar, Inc, formerly known as International Truck and Engine Corporation, introduced the industry’s
first high performance trucks. With this introduction, a very innovative and flexible electrical system employing
multiplexing technology was introduced. The system is standard on all high performance trucks and several
bus models. In addition, there are many options that can be ordered and / or added to the vehicle in the field.

The Diamond Logic® Builder (DLB) software combines the feature creation, programming and diagnostic
functions for the end user. This Diamond Logic® Builder User’s Manual describes the software in detail and
shows how to use it to maximize the efficiency and effectiveness of the industry’s first high performance truck’s
electrical system integration.




INTRODUCTION

WHAT IS MULTIPLEXING?

Multiplexing is the concept of transmitting multiple unique electronic signals over a much smaller number

of wires. Vehicular applications of multiplexing technology typically use just two wires for this function.
Multiplexing allows these two wires to carry electronic data that can control a variety of electronic equipment.
The number of wires needed to connect components is greatly reduced, which offers better reliability and
improved vehicle uptime. Although limited multiplexing had been used previously by Navistar, the introduction
of the industry’s first high performance trucks has fully exploited this technology.

COMPONENTS OF THE MULTIPLEXING SYSTEM

The multiplexed electrical system consists of the following standard or optional components:

Body Controller / Electrical System Controller
Remote Power Module(s)

Remote Air Solenoid Module(s)

Electronic Gauge Cluster

Switch Packs

Light Control Module (LCM)

HVAC Controls

Engine Controls

Transmission Controls

Anti-Lock Brake Module

Other modules, connected to a Data Link, supported by DLB
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Body Control Module (BCM)

The Body Control Module (BCM) is a body systems computer used to control many of the vehicle's electrical
functions. It is the heart of the multiplex system. When installed on trucks, all BCMs are located under
instrument panel. On bus applications, they are mounted to the underside of the dash.

The BCM receives inputs from driver controls, sensors, and switches providing outputs to vehicle loads,
gauges, relays, and remotely mounted modules. Software to control a vehicle’s specific electrical / electronic
features and components is programmed into the ESC / BC using a computer and the Diamond Logic®
Builder Fleet program.

Navistar has released three different generations of the BCM (Figure 2).

1. Electronic System Controller 2. Generation 2 Body Controller (BC)
(ESC) 3. Generation 4 Body Controller

Figure 2 Three Generations of Body Control Module (BCM)

NOTE — The BCM is commonly referred to as the Body Controller, Vehicle Control Module (VCM),
Electronic System Controller, as well as the Body Control Module.
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Remote Power Module (RPM)

Remote Power Modules serve as gateways into Navistar’s electrical system. Body Controller / ESC
programming allows modules to be programmed to control many different types of added body equipment.
The base package for integration includes a module, which contains six 20-amp outputs, for controlling lights
or other loads required for a vehicle’s application (up to 80 amps total). Remote power modules may be
controlled using pre-engineered features from Navistar or special customer developed features created using
Advanced Logic in the Diamond Logic® Builder program. Remote Power Modules also include six inputs that
can provide remote switching and feedback capability.

1. J4 output connector 4. Resistor
2. Remote power module 5. Body data link controller
3. Power supply 6. J3 remote input connector

Figure 3 Remote Power Module
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Remote Air Solenoid Module (RASM or MSVA)

Through the development of a family of Remote Air Solenoid Modules, air accessory devices such as horns,
PTOs, sliding fifth wheel locks, suspensions, transfer cases, differential locks, power divider locks, auxiliary
transmissions, and two-speed axles and more can be controlled by electric in-cab switches. Currently,
there are two types of Remote Air Modules, a seven-channel and a four-channel version. Both are factory
installed with in-cab switches.

NOTE - The seven-channel module is not available in post 2007 vehicles.

Figure 4 Seven-Channel Air Module

Figure 5 Four-Channel Air Module
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Electronic Gauge Cluster (EGC)

Located in the instrument panel, the Electronic Gauge Cluster includes the instrument gauges, warning
indicators, and an LCD digital display, which provide odometer, transmission gear indication, compass
heading, and outside temperature displays. The instrument cluster displays the crucial operational functions
of the vehicle. The number of gauges and their placement can vary depending on the options selected. An
audible alarm can be programmed in DLB to sound when certain gauge values read out of range.

The cluster’s gauges are controlled by the ESC / BC via the J1939 Data Link.

Figure 6 Base Instrument Cluster

The Base Instrument Cluster displays numerous functions, alerts, and indicators through analog gauges,
indicators, and an information LED screen. Depending on the cluster configuration that is selected, there can
be 6, 7, or 8 analog gauges in the instrument cluster that provide information to the operator. The Base
Instrument Cluster is available on 2017 and later International® vehicles.

An LED screen is located in the middle of the cluster that displays vital information to the operator. A push
button, located on the right, is used to scroll through the various menus.
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Figure 7 Premium Instrument Cluster

The Premium Instrument Cluster is an upscale version of the EGC that displays numerous functions, alerts,
and indicators through analog gauges, indicators, and an information LCD screen. Depending on the cluster
configuration that is selected, there can be 6, 7, or 8 analog gauges in the instrument cluster that provide
information to the operator.

The Premium Instrument Cluster utilizes a 5 in LCD screen, located between the tachometer and speedometer.
There are various menus that can be navigated through using the Cluster Display Control (CDC) on the
instrument panel to the lower right of the Instrument Cluster. A toggle joystick allows the operator to scroll
through various menus, and when pressed, a selection is made. The back button, represented by an arrow,
can be used to return to previous menus and screens.
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Rocker Switch Packs

The Rocker Switch Packs are provided in six and 12-switch modules. Commonly found in the center panel,
they are used to control loads such as fog lights, heated mirrors, and Power Take Off (PTO) options. Diamond
Logic® Builder software makes it easy to move and relocate switches.

Figure 8 Rocker Switch Pack 2007-2016 (Typical)

When multiple switch packs are utilized, they are daisy-chained together to eliminate excess wiring. Switch
actuators control what signals are sent from the Switch Pack.

On vehicles built between 2007 and 2016, the switch pack communicates on the switch data link. Switch
packs on these vehicles have a green Light Emitting Diode (LED) indicator that provides the operator with
information on the load and switch status.

On vehicles built in 2017 or later, the Switch Pack(s) communicate on the Human Machine Interface (HMI)
data link. These switch packs have an LED indicator with 7 different color options. The color of the LED is
dependent on the programmed feature code of the switch or the custom logic that is assigned to the switch.
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Light Control Module (LCM)

The Light Control Module (LCM) contains a light multi-switch for the fog lights, headlights, parking lights, and
the option for rear fog lights.

1. Headlight multiswitch 3. Switch actuator 1
2. Dimmer dial 4. Switch actuator 2

Figure 9 Light Control Module (typical)
The LCM is located in the dash panel on the left side of the steering wheel. The LCM communicates with the

Body Control Module (BCM) over the Low Speed HMI data link. The LCM also contains space for two optional
switch actuators, which can be changed and programmed with DLB.
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HVAC Controls

An electronic module located in the center of the instrument panel controls the HVAC system. The HVAC
controls eliminate complexity by controlling functions such as the air temperature and air outlet selection
with electronic motors.

Figure 10 Two Examples of HVAC Control Panels

Engine Control System
The engine control module shares engine information such as RPM, vehicle speed, water temperature, and oil

temperature with any component connected to the data link that requires the information. The engine also
receives commands for cruise control, clutch and brake status, and engine fan control from the ESC / BC.

Electronic Transmission Controls

The transmission controller communicates gear position, transmission oil temperature, and warning light status
with the electronic gauge cluster on the drive train J1939 Data Link.

Anti-lock Brake System (ABS)
The Anti-lock Brake System prevents wheel lock-up during vehicle braking events. The system communicates

with the ESC / BC and the engine controller to limit engine torque, disable retarders, and control the ABS, ATC
and trailer ABS warning lamps in the electronic gauge cluster.

10
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THE DIAMOND LOGIC® BUILDER SOFTWARE

The Navistar® Diamond Logic® Builder software provides the ability to program, diagnose, and simulate
features in the Electrical System Controller or Body Controller (ESC / BC) module. The Diamond Logic® Builder
program allows users to configure switches, the gauge cluster, and the parameters that are programmed

in the ESC / BC.

The Advanced Logic capability in DLB is covered in a separate manual. Advanced Logic provides the ability
to write custom features beyond what is offered by the advertised feature codes. It is not usually offered at
the Dealer level and is primarily intended to be used by Body Builders. Dealers do have the ability to view
and diagnose Advanced Logic when it has been installed on a vehicle.

Figure 11 Diamond Logic® Builder, Main Window

1
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GETTING STARTED
SYSTEM REQUIREMENTS

Minimum Requirements

*  Pentium® lll class processor or greater
* 500 MHz processor or faster

*  Windows 2000° or greater

512 MB of RAM minimum

* 150 MB of free hard disk space

* High speed Internet connection

*  One or more RP1210A compatible communication devices (See Recommended Adapter below)
Recommended Requirements

*  Pentium® IV class processor or greater

* 1 GHz processor or faster

Improved system performance will occur with the installation of increased RAM
Recommended Adapter

*« NEXIQ™ Technologies — USB-Link2

Other interface cables MAY work with the Diamond Logic® Builder program.
Communication Link Drivers

* DLB uses standard RP1210A drivers for communication. The drivers are specific to the communications
device and are not installed with DLB.

12
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INSTALLING THE DIAMOND LOGIC® BUILDER SOFTWARE

It is strongly recommended that all Terminate and Stay Resident (TSR) programs like the Quicktime® program,
CD player programs, or Pocket PC programs be terminated prior to loading or starting the Diamond Logic®
Builder software. These programs interfere with the efficient operation of the Diamond Logic® Builder program
and can cause errors reading and programming the ESC / BC.

To install the Diamond Logic® Builder software:

1.

If a version of the DLB software that was installed from disc (DLB Fleet Version) is already present on the
computer, that version must be uninstalled before the Internet download version can be installed.

2. Prior to installation, a DLB product key must be obtained for each computer on which the DLB software is
to be installed. Product keys expire after a year and must reactivated to allow access to the program.

3. Using the web browser of your choice, navigate to the Diamond Logic® Builder page on Navistar’s
service software site:
http://www.navistarservicesoftware.com/index.php/dib/

4. Select the Download button to download the DLB software.

5. When the file has finished downloading, run it (Diamond Logic Builder Setup.exe) to begin installation. The
first page of the Setup Wizard appears.

Figure 12 Setup Wizard, Page 1
6. Click Next.

13
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Figure 13 Setup Wizard, Page 2
7. Read through the License Agreement. When finished, click | Agree to proceed with installation.

When installation is complete, the final page of the wizard is displayed.

14
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Figure 14 Setup Wizard, Page 3
8. Ensure that the Run Diamond Logic Builder box is checked.
9. Click Finish to launch the program.

The first time DLB is installed on a specific computer, the user is prompted to enter their product key.

Figure 15 Product Key Entry
10. Enter the DLB product key obtained for this computer and then click OK.
+ If the key was not entered correctly (or there is some other problem), an error message will be

displayed. Refer to Installation Error Messages (page 19) for more information. Resolve the issue
indicated before proceeding.

15
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+ If the key was entered correctly, the following window is displayed. Proceed to Step 11.

Figure 16 Existing User Prompt

11. If you already have a Navistar-issued username and password for applications such as DLB, NavKal™ or
NED, click Yes and proceed to Step 15.

If you DO NOT already have a Navistar issued username and password, click No and proceed to Step 12.

Figure 17 New User Registration

12. The Registration window appears. Fill in the information in this window. Required fields are indicated
by an asterisk ().

13. Click OK. Once registration is completed successfully, the following message is displayed:

16
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Figure 18 Username Successfully Created

14. An email will be sent to the address provided on the registration form. Follow the instructions provided in
this email to complete the registration process. When finished, click OK in the window shown above.

17
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IMPORTANT - You MUST change your password by following the instructions provided in the email before
proceeding. The default password cannot be used to log into the application.

15. The User Authentication window appears. Enter your username and password and click OK.

Figure 19 User Authentication Window
Once you are logged in for the first time, the software will start and begin to update itself.

NOTE - The Diamond Logic® Builder program will not function until the user has successfully logged in
at least once while connected to the network. The user may need to consult with the technical computer
support staff if the Diamond Logic® Builder program cannot connect to the Navistar site. Error messages
will be generated if connection to Navistar fails. Your Internet firewalls must be configured to allow
two-way communication to the following Navistar host names:

* d2mutuy95x2dyc.cloudfront.net

¢ evalueb.internationaldelivers.com

Be aware that the underlying IP addresses for these hosts are subject to change and may vary by region.
When possible, grant access by host name rather than IP address.

18
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Installation Error Messages

The error messages that may appear during the installation process are self explanatory. Some sample
messages are included in the table below:

Code | Text

801 The product key provided does not match the software that you are attempting to activate. Please
re-enter the product key to verify or visit the Diamond Logic® Builder support page for assistance.
http://www.navistarservicesoftware.com/index.php/dib/

803 | You've exceeded the number of registrations allowed for this product. Please visit the Diamond Logic
Builder support page for assistance.
http://www.navistarservicesoftware.com/index.php/dlb/

810 An Internet connection to the Diamond Logic Builder server could not be established; press ‘OK’ to
continue in offline mode. Your license will be verified each time you log into the system. You can
keep accessing Diamond Logic Builder offline for 30 remaining days. If a connection to the Diamond
Logic Builder Server cannot be established by then, your product will stop working.

812 | On some computers, DLB has to be run in administrator mode. Follow these steps:

1. On the Windows desktop, right click the DLB icon.
2. In the right click menu, select Open File Location.
3. Right click Diamond Logic Builder.exe.
4. Select Run as Admin.
814 | You have already activated your maximum number of Usernames permitted by your license.

19
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LAUNCHING THE DIAMOND LOGIC® BUILDER SOFTWARE

NOTE - For installation instructions, refer to Installing the Diamond Logic® Builder Software (See
Installing the Diamond Logic® Builder Software, page 13).

To launch Diamond Logic® Builder, do one of the following:

*  Double click the Diamond Logic® Builder program icon on the Windows desktop.

* Select Diamond Logic® Builder from the Programs list in the Windows Start menu.

=5

0000406263

Figure 20 DLB Program Icon

After a few moments, the following Navistar message will appear:

Figure 21 DLB Splash Page

The User Authentication window appears. Enter your DLB username and password and click OK.

20
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Figure 22 User Authentication Window

NOTE - It is possible the user will also see a brief notice that the software is updating. Software updates
occur whenever they are available, when the user starts the program, while connected to the Internet.

21
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When the Diamond Logic® Builder software is started, the main window appears.

Figure 23 DLB Main Window

22
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CONNECTING TO THE VEHICLE

The computer is connected to the vehicle using a RP1210A compliant interface device.

NOTE - Navistar requires a RP1210B compliant interface cable that supports J1939 and J1708 standard.

Figure 24 NEXIQ USB Link 2 Interface Device

There are two cables included with the interface device. One of the cables links the Data Link Connector (DLC)
on the vehicle to the interface device.

23
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On most International® trucks, the Data Link Connector is located underneath the instrument panel, to the far
left, on the driver’s side.

On most IC Bus™ models, the Data Link Connector is located underneath the instrument panel, in the middle
of the panel.

Figure 25 Data Link Connector

The other cable connects to a USB port on your EZ-Tech® / computer to the interface device.

Figure 26 EZ-Tech®

24
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Preferred interface devices are available from Navistar. However, other interface cables MAY work with the
Diamond Logic® Builder program. The type of cable being used needs to be selected in the Diamond Logic®
Builder program. In addition, the correct cable driver needs to be installed on the computer.

Figure 27 Selecting the Interface Cable Type
Contact the interface cable supplier or visit the supplier’s website for updated software drivers.
NOTE - If communications problems are experienced with one of these cables, disconnect the cable

from the truck, reconnect and try again. Pressing the F6 key on the computer will toggle between
activating and deactivating the Com Link.

25
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VERIFYING THE CONNECTION BETWEEN THE COMPUTER AND THE VEHICLE

This section describes how to tell if the vehicle is connected correctly to the computer. Launch the Diamond
Logic® Builder software and then connect the interface cable between the computer and the vehicle.

1. Connect / Disconnect toolbar icon 2. Connect / Disconnect indicator

Figure 28 Main Window, Connected / Not Connected Icons

The Connect / Disconnect indicator (shown above disconnected) is in the lower right corner of the Main
Window. The Connect / Disconnect toolbar icon will also reflect the current connection status.

The icon as shown below indicates that the computer is properly connected and is communicating with the
data link in the vehicle.

-

Figure 29 Connected Icon

26
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If the computer is not connected or communicating with the data link in the vehicle, it will appear as shown
below:

€0

Figure 30 Not Connected Icon

NOTE - If the interface cable is connected correctly to the computer and this icon does not appear,
check to ensure the correct cable is assigned to the applicable port under the Tools menu. In addition,
ensure the correct port has been selected and that the Com link is active.

The indicator lights, on the Interface Cable, should identify when the cable is connected and functioning
properly. If the Diamond Logic® Builder software does not show a Connected icon, tap the F6 key on the
computer. Communication with the truck should resume in a few seconds.

When the computer, running the DLB software, with a properly configured interface cable, is connected to
the module, a status line will scroll across the bottom of the DLB screen. After data has been collected the
module information should be populated in the “Detected” column of DLB. If this column is not populated, DLB
is not communicating with the module.

NOTE - You will not be able to Diagnose or Program a module when the module information does not
populate the “Detected” column.

If the module information does not populate the “Detected” column, recycle the key, then disconnect and
reconnect the interface cable from the diagnostic connector on the truck.

If you cannot connect to the module, try to connect to another truck to rule out a problem with your computer
or interface cable. Try to connect to the module with a different computer and interface cable to eliminate a
problem with the truck or module.

27
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MENU AND TOOLBAR OPTIONS

In this section, the menus and toolbar will be briefly outlined. In subsequent sections, the various windows,
buttons and functions will be described in detail.

MAIN WINDOW

This is the main window of the Diamond Logic® Builder program.

1. Menu bar 3. Tabs
2. Toolbar

Figure 31 The Main Window

Each of the three items called out in the figure above provide access to some of DLB’s functions, and each
will be covered in detail in the following sections.
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MENU BAR

The menu bar at the top of the main window contains seven dropdown menus.

Figure 32 Menu Bar

The menus are defined as follows:

Name Description

File Used to manage vehicle data.

Edit Used to manipulate and edit vehicle data.

View Used to view data from different perspectives.

Advanced Used to view any advanced logic programmed on the vehicle.
Logic

Tools Used to manipulate data when connected to selected vehicle.
Diagnostics Used to troubleshoot a vehicle.

Help Used to access the software’s help system.

Each menu is described in detail in the following sections.
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File Menu
Figure 33 The File Menu

Name Shortcut Description

New CtrI+N Opens the New Template window, which is used to define a new template
from scratch.(See Creating a New Template from Scratch, page 101) .

Get From Ctrl+H Opens a window that allows VIN files to be requested from Navistar over

History the Internet. (See Getting Vehicle Configuration History, page 96).

Make Template | Ctrl+M Allows the operator to make a template by copying a selected VIN or
template.(See Creating a New Template from an Existing Template or VIN,
page 102).

Save Ctrl+S Saves changes made to a VIN.

Revert... CtrI+R Allows the operator to undo changes and revert to a previously saved
version of the VIN.

Delete Deletes the selected vehicles.

Set Vehicle Sets the default directory in which DLB will save VIN and template files.

Directory...

Import... Ctrl+l Imports vehicle file(s) from a folder other than the default directory.
(The import and export functions are typically used to copy files from one
computer to another.)

Export... CtrlI+E Exports vehicle file(s) to a folder other than the default directory.

Print Vehicle... | Ctrl+P Prints all vehicle parameters and information.
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Print General... | Ctrl+Shift+P | Prints vehicle selection screen information. This function changes when
you change tabs. For instance, if you just want to print the switch positions,
go to the Center Panel tab before you select the File menu.

Close Alt+F4 Closes the DLB program.

NOTE — These menus could contain additional items depending on your DLB access permissions.
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Edit Menu

The Edit Menu allows the user to manipulate and edit data.

Figure 34 The Edit Menu

The items in this menu are defined as follows:

Name Shortcut | Description

Apply Ctri+T Applies a template to a selected vehicle. (See Applying a Template, page 104).

Templates

Update Updates Navistar software features without any programmable parameter

Software changes.

Use Default Allows resetting of pin mapping, gauge location and switch mapping to default
locations.

Add Modules Adds modules to the selected vehicles and templates.

Remove Removes modules from the selected vehicle.

Module

Apply Selected Applies any selected campaign that is shown in the Campaign Tab.

Campaign

Cut Ctrl+X Same as the standard Windows editing function.

Copy CtrlI+C Same as the standard Windows editing function.

Paste Ctrl+V Same as the standard Windows editing function.
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View Menu

The View Menu allows the user to view additional data and / or change the units of the data.

Figure 35 The View Menu

The items in this menu are defined as follows:

Name

Description

Unsent History

Lists all vehicle programming files that have not been sent to Navistar.

Advanced Shows all vehicle signals in diagnostics.

Diagnostics

Units Allows selection of measurement system.
English: uses English units for measurements.
Metric: uses metric units for measurements.

Refresh Rereads data and refreshes screen display.

33



MENU AND TOOLBAR OPTIONS

Advanced Logic Menu

Advanced Logic allows the user to view logic blocks. Advanced Logic is active only when a logic block
under the Advanced Logic tab is selected.

Figure 36 The Advanced Logic Menu

The Advanced Logic menu includes the following items. There are more options displayed when logged in with
Advanced Logic permissions.

NOTE - Advanced Logic programming is available only to personnel trained and certified at this level.

Name Description
Print Prints ladder logic and selected logic block.
Ladder Details Shows mapped signals on ladder.
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Tools Menu
Figure 37 The Tools Menu
Name Shortcut | Description
Activate Com Link | F6 Turns on / off continuous controller hardware scan on communications link.
Select Com Link Allows for the selection of a communications port to match selected cable.
Get Data F7 Reads vehicle data from controller.
Set Odometer Programs the current mileage into the gauge cluster. (See Cluster
Odometer Programming, page 124).
Program F8 Writes selected vehicle configuration into controller.

Reboot Module

Allows a reboot of a module without disconnecting the power feed to the
unit.
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Diagnostics Menu

The Diagnostics Menu allows the user to diagnose a vehicle. Most diagnostic items may be used only when
the Diamond Logic® Builder program is placed in Diagnostic Mode.

Figure 38 The Diagnostics Menu

The Diagnostics Menu contains the following items:

Name Shortcut | Description

Erase Faults F10 Erases diagnostic faults.

Diagnose F9 Places DLB into Diagnostic Mode while connected to a vehicle.
Simulate F11 Places DLB into Simulate Mode. No vehicle connection required.

Simulate Slowly

When DLB is in Simulate Mode, adjusts the speed of the
simulation. This is typically used to slow down simulation speed
when attempting to observe events that occur very quickly.

Cluster Bulb Test

Turns On / Off all ESC / BC driven (not CF model) gauge cluster
warning lights.

Indicator Lights Test

Turns On / Off all ESC / BC driven (not CF model) indicator lights.

Record / Arm

Starts / Stops DLB Data Recorder.

Edit Triggers

Sets up signal triggers for recording.

New Sessions

Opens a new signal recording session.

Open Session

Opens an existing signal session.

Save Session

Saves a signal session to the computer memory device.
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Save Session As Closes any open Session.

Close Session Closes any open Session.

Save Graph Data Saves recorded signal graph data to a specified file.
Open Graph Data Opens a recorded signal graph data from a specified file.
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Help Menu

The Help Menu allows the user to seek information about the program’s terms and processes.

Figure 39 The Help Menu

Name Shortcut| Description

Help F1 Opens Help function. Help includes: configuring vehicles,
Advanced Logic, programming icon types, ladder logic,
structured logic, units of measure, diagnostics and
acknowledgements

Messages Displays messages from the system when a user is online.

These messages appear at login if they are not turned off,
on the message window.

About Diamond Logic® Builder

Shows the Diamond Logic® Builder program version
information.

Send Logs

View Logs

Logging is used only by DLB support and should only be
turned on when directed by engineering.

Registration...

Displays registration information for DLB on this system and
other computers using the same product key.

If you have a multi-user license for the DLB software, the first
user to install the software with your product key becomes
the administrator for the individual user licenses. Some
items on this menu are visible only to the administrator.
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Registration Sub-Menu

Name

Description

View Registration
Information...

Provides information about the product key, including parts of the key values,
the system name associated with the key, and information about time left
before the expiration expires.

Extend / Change Edition...

Provides the option to enter a new product key to change or extend the
days left until the registration expires.

Request Additional Users...

This option requests additional Usernames to be used with DLB.

Unregister this machine...

This option unregisters this installation of DLB. This will force DLB to close.
Reopening DLB on this computer will automatically reregister the installation.
To use this Product ID on another computer, install it on the other computer

before reopening it on this computer.

Figure 40 Registration Information Window
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TOOLBAR

The toolbar at the top of the main window displays buttons that correspond to many frequently used functions
in the menu bar.

1

5
"_"IE]’ELJ%%J@'

2 3 4

6 7 8 9 1

@ -4)- 630”Get Data v y Program v

Figure 41 The Toolbar

The icons in the toolbar include the following:

0000410383

Write selected vehicle configuration into

Item | Icon Description
1
j Create a new template.

2 : .
Save vehicle and template changes on your computer. However, changes will
not be programmed into the vehicle until the program function is invoked.

3

¢ I | Apply configuration to selected vehicles.

4
Get vehicle information from Navistar.

5 . : :

@ v Update Navistar® software features and kernel on selected vehicles without
@ any application or programmable parameter changes.

6
Print configuration for selected vehicle.

7

-"- Turn On / Off continuous controller hardware scan on communications link.

8

MGet Datav | Read vehicle data from controller.
9

controller.
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10
— Edit vehicle mode for the selected vehicle. Turns off Diagnostic Mode and
— Simulate Mode.
11
-M Places DLB in Diagnostic Mode when controller is detected on communications
link.
12
ﬁ (Green) Places DLB in Simulate Mode for the selected vehicle configuration.
13
(Red) Adjust the speed of the simulation.
14
. Clear fault log and previously active faults from cluster.
15
$ Start signal recorder when controller is detected on communications link.
16

!

Go Online / Offline with the Internet connection.
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TABS AND SUBTABS
USING DATA TABLES IN THE DLB INTERFACE

Most of the tabs in DLB display their information as a table. The tables provide a number of functions for
viewing and sorting the presented data:

* Enable or disable the display of each column
» Sort rows by the contents of a selected column
« Bring rows that contain specified text or values to the top

* Change the width of individual columns

Enabling and Disabling the Display of Individual Columns

Right-clicking any column heading will display the Column Selection Menu.

Figure 42 Column Selection Menu
Selecting a column name in this menu adds or removes its check mark.

*  Checked columns will be displayed in the table
¢ Unchecked columns will be hidden in the table
NOTE — Most column selection menus in DLB include two final items that are NOT column names: “Sort

matching rows to the top” and “Clear matches.” These functions are part of DLB’s filter feature.(See
Bringing Rows that Contain Specified Text to the Top, page 44)
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Sorting Rows by the Contents of a Specific Column

Left click any column header to sort the list by the contents of that column. Clicking the same heading again
reverses the order of the sort (indicated by the up or down arrow on the right end of the clicked heading).

Figure 43 Sorting Downwards by Contents of Parameter Column

Figure 44 Sorting Upwards by Contents of Parameter Column
Note that each column has its own sorting rules:

* A column that contains text entries is typically sorted alphabetically.
* A column that contains numerical entries is typically sorted by value.

* A column whose entries are all checkboxes typically would sort the entries into checked items vs.
unchecked items.

« efc.
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Bringing Rows that Contain Specified Text to the Top

Refer to the figure below for items in parentheses.

1. Filter button 2. Find window
Figure 45 The Filter Feature

1. Click the Filter button (Iltem 1) in the upper-left corner of the table. The Find window appears (ltem 2).
2. Enter the text that you wish to search for.

3. Click OK.

Any rows that contain a match for the entered text will now appear at the top of the table.

NOTE - The Find window can also be opened by selecting “Sort matching rows to top” in the Column
Selection Menu (Figure 42).

To return the rows to their original order, select “Clear Matches” in the Column Selection Menu (Figure 42).

Changing the Width of Columns

1. Column border (3)
Figure 46 Column Width

The width of columns can be changed by clicking the border between any two column headings (Figure 46,
Item 1) and dragging the border to the left or right.
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SELECT TAB

The Select tab is shown by default when the program is started. This is the main page and is used to select the

vehicle, to display relevant information, and to manage vehicle data. When using any of the other tabs, the

user can return to this main page by using the Select tab.

Figure 47 The Select Tab

Descriptions of Columns on the Upper Half of the Tab

The columns that can be displayed in the top portion of the Select tab include the following:

Column Name

Description

VIN

Vehicle Identification Number

Template Displays the ESC / BC serial number either from History or from the installed ESC /
BC, depending on the source of the VIN

Configuration The number of times this VIN or template has been modified

Version

Status Current status of the file, whether modified, unsaved, etc.

Base Revision

The revision of the VIN, before the current configuration
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Model Sales model of the vehicle

Software Version Software version tied to the file

Last Changed By | The ID of the last person to change the file

Last Changed When the file was last changed
Date

VIN Right Click Menu

Right-clicking a VIN will open a dropdown menu. The options in this menu can also be found in various menus
of the menu bar. However, they are collected in this dropdown as a convenience to the user.

Figure 48 VIN Right Click Menu
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Selecting a VIN

1. Advanced Logic tab 3. Center Panel tab
2. Connectors tab 4. Cluster tab

Figure 49 Additional Tabs Displayed when a VIN is Selected

Click on a listed VIN to select it. Four additional tabs are displayed when a VIN is selected (Figure 49, ltems 1,
2, 3 and 4).

The Module List

When a VIN is selected, a list of the modules programmed on the vehicle will be displayed in the bottom part of
the window. When you are connected to a vehicle, this list will be displayed if the module is communicating
with the ESC / BC.

Figure 50 The Module List
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Right-clicking on any of the modules will open a dropdown menu that may provide additional options for that
module. Options that are grayed out are not available for the selected module.

Figure 51 Module Right Click Menu

The options in this menu are listed below:

Name

Description

Update Module

Updates Navistar software on the selected vehicle.

Get Module Data

Reads the selected vehicle configuration from all programmable modules.

Remove Module

Removes the selected module from this DLB session. This option does not affect the
programming of the module.

Change Module
Password

Changes the module password (only if the module has a password feature).

Program Module

Writes the current configuration to the selected module only.

Reboot Module

Reboots only the selected module operating program.
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The Right Panel

When a VIN is selected, information about the selected vehicle populates the right side of the window. When
you are connected to a vehicle, DLB will also display information about the detected ESC / BC.

Figure 52 Select Tab Right Panel

The items displayed in this area are listed in the table below:

* Selected Vehicle — Information on the vehicle currently selected.

« Detected — Information on the vehicle connected to DLB.

Name Description

VIN Vehicle Identification Number.
Description ESC / BC processor information.
Serial ESC / BC serial number.

Hardware Identifies the version of the ESC / BC.

Configuration

Number of times this VIN or template has been
modified.
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Kernel

Identifies the release version of the core program in
the ESC / BC.

Data Version

Release revision of software feature codes.

State

Displays the State of the ESC / BC (Ex: blank).
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ADVANCED LOGIC TAB

This section will describe the Advanced Logic tab and the information displays associated with it.

NOTE - Advanced Logic programming is not available to Level Il users. This capability is restricted to
Level lll users.

NOTE - There is additional information about Advanced Logic under the Help menu, and a separate
manual provides more detail about Advanced Logic Programming.

Figure 53 Advanced Logic Tab
The Advanced Logic tab allows users to view logic blocks. The tab has four main parts:

» The Advanced Logic List (upper left)
» Display area (lower left). The figure above shows the most common display mode — Ladder Logic.
» Variable selection tabs (upper right)

* Variable listings (lower right)
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Advanced Logic List

This area of the Advanced Logic tab allows the user to select which logic block the user will be programming
or editing and lists all logic blocks of a selected vehicle or template.

Figure 54 Advanced Logic List
Selecting a Logic Block reveals its particular ladder logic in the display area below. Just below the Advanced
Logic List are three sub tabs that allow the user to choose either the Ladder Logic view (as shown) or the
Structured Logic view (for advanced programmers) and a Diagnostics tab.
NOTE - The Diagnostics sub-tab should contain a detailed description, written by the log block creator.
This should describe the operation of the logic and provide contact information. This can be very helpful
if the creator provides the documentation.

Advanced Logic List Columns

The columns in the Advanced Logic List include the following:

Name Description

Logic Block Logic Block filename. Logic Blocks make up the advanced logic on a vehicle. It
is a way of organizing advanced programming, such as vehicle lighting in one
block, PTO functions in another, emergency lighting in another.

Proprietary Sets up a check box that allows the user to choose proprietary format.
Description Logic Block description.

Date Edited Date created or edited.

User Identifies the user who last edited this Logic Block.

Active When checked, the Logic Block is included in the vehicle configuration.

If the user makes a Logic Block proprietary, then diagnostics are restricted to the
individual that created it. Therefore, a vehicle with Advanced Logic that is set to
proprietary will not be easily diagnosed or serviceable by International dealers. See the
Diamond Logic® Builder Software User Manual — Advanced Logic Programming (Level
3 Permissions) for more information on proprietary logic.

52



TABS AND SUBTABS

Display Area

Once an item in the logic block list is selected, the left-side display area will populate with a ladder diagram
of the programmed functions. The ladder diagrams are created and may be edited in this screen, if the

user has Advanced Logic permissions.

Figure 55 Advanced Logic Display Area

The display area itself is resizable. Using the cursor, the width of the display area can be increased or
decreased. Doing so will also change the width of the other displayed areas.
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My Variables

This area of the Advanced Logic tab allows the user to view variables used in the advanced logic programming,
if there are any, on this vehicle.

Logic Blocks are built using the inputs and outputs of the associated modules in the Advanced Logic tab.

Clicking and dragging these inputs and outputs to the left side of the window allows the user to build what is
known as “ladder logic.”

Figure 56 My Variables List
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My Variables Columns

The headings under the My Variables tab include the following:

Name

Description

Icon

Displays the variable name icon that appears in the ladder logic.

Custom Variable

Custom name the user has given to the custom variable.

NOTE: No spaces or symbols such as + - & * # may be used.

Used In The logic block in which the custom variable is used.

Written To Whether it is possible to write to the variable or not.

Timer Whether the variable is a timer or not.

Semaphore The variable can be written to; however, other internal variables may take precedence
over your set variable.

Used True when the variable is used in a logic block or the mapped signal is used on the
vehicle.

Description Custom description the user has given to the custom variable.

Signal / Value The system name for the selected signal.

Unit Unit of measure used to display the variable, such as seconds or On / Off.

CFG Unit The system unit of measure for the selected variable.

Signal Description

Description for the variable. If no text is in this field, the parameter is an internal value.

Writable

Whether the user can write to this value or monitor it or use it to drive other features.

Enabled On Truck

Check if the variable is enabled and used on the truck.
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FEATURES TAB

The Features tab displays features and / or parameters for the selected vehicle.

Figure 57 Features Tab with Features Sub-Tab Selected
The Features tab has three sub-tabs:

¢ Features
« ESC

»  Custom Logic

The first two of these sub-tabs are always available. The Custom Logic sub-tab will appear only if parameters
have been assigned by advanced logic.
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Features Sub-Tab

The Features sub-tab is divided into two sections:

» Available Feature list (upper section)

* Programmed Parameter list (lower section)

Additionally, a Make Session button appears at the top of the tab.

Available Features List

This list displays the features available for the selected vehicle and indicates whether each feature is currently

installed.

Figure 58 The Available Features List

The columns in this list include the following:

Name Description

Feature Removing the check from this item hides the Features column in the Available Features list.
This column displays the features available for the selected vehicle, in numeric order.

Description Removing the check from this item hides the Description column in the Available Features
list. This column contains a brief description of each listed feature.

Installed Removing the check from this item hides the Installed column in the Available Features list.
This column indicates whether the feature is installed on the selected vehicle.
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Programmed Parameter List

This table lists the programmed parameters for the selected vehicle’s features.

Figure 59 List with Numerical Parameter Selected

When a row is selected in the Programmed Parameters list, a value entry field and a description of the
selected parameter appear below the list.

NOTE - The format of the value entry field displayed will vary depending on the type of programmed
parameter selected. The image above shows a parameter that accepts a numerical value within a
specified range. The image below shows a simple On / Off parameter.

Figure 60 List with ON / OFF Parameter Selected

The Programmed Parameter list includes the following columns:
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Name Description

ID Numerical label to identify the programmed parameter. Useful when speaking with
Tech Central.

Parameter Signal name for the programmed parameter.

Unit The unit of measure for the programmed parameter.

Description A brief description of the programmed parameter.

CFG Value Raw data value used by the ESC / BC software. This column is normally turned off
since it is of no value to the typical user.

CFG Unit This is the unit of measure for the raw data value used by the ESC / BC software. This
column is normally turned off since it is of no value to the typical user.

Set With When the box in this column is checked, the programmed parameter value will be set on

Template the vehicle when the template is applied.

The Make Session Button

The Make Session button can be used to create a diagnostic session from the selected feature and will
display the signals that are related to the feature. This is very helpful when trying to select signals to watch,
while diagnosing a feature.

Figure 61 Make Session Button

Refer to the Using “Make Session” to select WATCHED Signals section. (See Using “Make Session” to
Select WATCHED Signals, page 130)
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ESC Sub-Tab

The ESC sub-tab displays a list of the programmed parameters installed on the selected vehicle.

Figure 62 The ESC Sub-Tab

The columns on the ESC sub-tab include the following:

Name Description

ID Numerical label to identify the programmed parameter. Useful when speaking with
Tech Central.

Parameter Signal name for the programmed parameter.

Unit The unit of measure for the programmed parameter.

Description A brief description of the programmed parameter.

CFG Value Raw data value used by the ESC / BC software. This column is normally turned off
since it is of no value to the typical user.
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CFG Unit This is the unit of measure for the raw data value used by the ESC / BC software. This
column is normally turned off since it is of no value to the typical user.

Sort Matching Used to find matches anywhere on the table and bring them to the top of the list.

Rows to Top

Clear Matches Select this item to clear any found matches and return the list to the sort order for the
most recently clicked column heading.
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FAULTS TAB

The Faults tab allows the user to view and clear diagnostic codes that relate to the vehicle’s body electrical
system.

NOTE - The user must be in Diagnostic Mode with the key in run position for diagnostic trouble codes

to be displayed.

Figure 63 Diagnostic Mode Icon

Enter Diagnostic Mode by clicking the Diagnostic Mode icon in the toolbar while you are connected to and
communicating with the vehicle.

Once connected to a vehicle, with the key in ignition or run position, engine not running, the Faults tab will
display any available faults. However, DLB will not display any engine-related diagnostic trouble codes.

Figure 64 The Faults Tab

The columns on this tab are described below:

Name Description

SPN Suspect Parameter Number: Number that indicates the Major System that is
experiencing a failure mode.

FMI FMI is a number for “Fault Mode Indicator.” Currently this value is always 14 for
“Indeterminate” as per the SAE J1939 specification. The FMI for the Diamond Logic®
electrical system is currently displayed under the Byte 8 column listed below.

Byte 7 Number that indicates the sub-system that is experiencing a failure mode.

Byte 8 Number to describe the detailed fault mode such as open circuit or shorted to ground.
Active Indicator to show whether a fault is currently active or inactive.

oC Occurrence Count: Number of times a fault has gone active and then inactive.
Message Text description of the numerical fault code.

Comment Explanation of Message Description.

Probable Cause Probable cause of the fault.
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Pins Module pin and connector associated with the fault code, if applicable.
Module Text name of module associated with the fault code, if applicable.
Address Text name of module associated with the fault code, if applicable. Address of the

module logging the fault. Currently, this number is always 33 for the ESC / BC.
Recommend turning this column off, leaving more space for other columns, until later
enhancements provide more varied data.

NOTE - The SPN, FMI, Byte 7, and Byte 8 columns together make up the diagnostic trouble code. All
four of these columns should remain selected.
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CONNECTORS TAB

The Connectors tab allows the user to view modules programmed for the selected vehicle. The sub-tabs under
the Connectors tab are used select a module to view.

NOTE - A different view for the ESC / Body Controller will be displayed, depending on the model of the
vehicle.

Figure 65 Connectors Tab Showing Electronic System Controller
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Figure 66 Connectors Tab Showing Generation 4 Body Controller
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Connectors Tab Modules

Each sub-tab under the Connectors tab represents a particular module. If the sub-tab’s name is italicized,
the module is inactive / not configured.

Figure 67 Module Sub-Tabs

The sub-tabs are named as follows:

Name Description

ESC Electronic System Controller

MSVA 1 Modular Solenoid Value Assembly 1
MSVA 2 Modular Solenoid Value Assembly 2
RPM X Remote Power Module X

NOTE — Some selected VINs may not display anything other than the ESC / Body Controller, depending
on the model of the vehicle.
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Module Not Configured

In the figure below, the name of the RPM 2 tab is italicized, indicating it that the RPM 2 module is not
configured. When the tab is selected, it displays the RPM 2 module and its connectors. There are no labels
associated with connectors that are not being used.

Figure 68 Module Not Configured
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Configured Module

In the figure below, the name of the RPM 1 tab is italicized, indicating that the RPM 1 module is configured.
When the tab is selected, it displays the RPM 1 module and its connectors.

Figure 69 Configured Module

The connector pin-outs that are used are labeled with the signals associated with that pin. The outside signal
names are internal signals used by the system processor. Other signal names are provided for usage by the
Advanced Logic user. General-purpose names are applied to signals that have not been used by Advanced
Logic. Those signals that are in bold have been used in Advanced Logic features.
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Selecting a Connector

When a module connector is selected, the connector in the module view changes to a dark gray color. The
newly selected connector and pin-out information appears in the right-side pane.

Figure 70 Selecting a Connector

If the connector data is wider than the space provided, horizontal scroll bars will be displayed to allow the user
to scroll left and right.

NOTE - The location of the input signal determines whether it is ground or 12V active. For example in
the figure above, pin 20 is a ground active signal. If it was 12V active, the bold print would be on the left
and RPM1_Input3_GND would be listed on the right in lower case.
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Selecting a Connector Pin

Hovering over the pin with the mouse pointer will cause a brief description of the pin’s function to appear.

Figure 71 Selecting a Connector Pin

When connected to a vehicle and DLB is in Diagnostic Mode, the user can lock on an output connector pin

command in the connector view. When a connector pin label is selected, the Module Tab, connector pin, pin
label, and pictured module connector are all highlighted in yellow. Selecting the Signals tab will then display
the highlighted signal for additional information. In the sample figure below, PTO_Output has been selected.
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Signals Tab View of Selected Pin
When a pin is selected, selecting the Signals tab will show the selected pin signal description and details,

if the applicable signal is available in the list of signals selected. Select the ESC Signals sub-tab to see all
signals that apply to this vehicle.

Figure 72 Signals Tab View of Selected Pin
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Selecting Multiple Pin Signals

To select more than one pin, hold down the “Control” key and then click the desired pins.

Figure 73 Multiple Pins Selected
Deselecting a Pin

To deselect a pin, hold down the Control key and then click on pin to deselect.
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Selecting a Pin Used in Advanced Logic

A pin used in Advanced Logic can be selected by clicking on the pin itself, on the pin command text, or on the
pin request text. The text, the pin, and the Module Tab will then all be highlighted in yellow.

Figure 74 Selecting a Pin Used in Advanced Logic
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Selecting the Signals tab will then show the selected pin signal description and details.

NOTE - The signal highlighted will depend on where the user clicks. For example, clicking the pin itself
or the pin name text will highlight the output request signal. Clicking the command text will highlight
the output command signal. See figures below.

Figure 75 Signal View when the Output Pin or Pin Name is Clicked

Figure 76 Signal View when the Output Pin Command is Clicked
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To unselect an output pin, hold down the Control key and then click on the pin to be deselected. Alternately,
the user can click on another VIN or template.

Figure 77 No Pins Selected

These functions apply to the ESC and Air Solenoid Module views as well.
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SIGNALS TAB

The Signals Tab allows the user to view detailed information about each electrical signal that is available for
use by Navistar engineered features and by Advanced Logic, if applicable.

Several sub-tabs are displayed when the Signals tab when it is selected. Among others, these typically
include ESC Signals, Master List, Watched and Graph.

The upper section each sub-tab (except Graph) displays a list of signals associated with the selected vehicle.

The lower section displays, if applicable, associated ladder logic as it pertains to the selected signal from
the upper section.

Figure 78 The Signals Tab
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Notice that in the figure below, a help message is displayed. Throughout the DLB program, hovering the cursor
over an item can display help popups such as this one.

Signals Tab Columns

Figure 79 Mouse Hover Help Message

With the exception of the Graph sub-tab, all of the sub-tabs on the Signal tab present data in a tabular format.
All of these tables have the same column headings:

Name

Description

Custom Signal

Displays the custom signal name assigned by the Diamond Logic® Builder software
user.

Signal Displays internal system name for each signal.
Pins Displays internal system name for each signal.
Signal Type Displays, if applicable, generated signal type such as analog, digital, J1939, or

1708.

Physical Signal

Name of the signal used by the system controller. This column would normally not
be displayed since it is of no use to the Diamond Logic® Builder software user.

Index Entry in the electrical system data table. This column would normally not be
displayed since it is of no use to the Diamond Logic® Builder software user.

Description Displays the logic description.

Unit Unit in which the variable is displayed, such as seconds or On / Off.

Watch Displays the watched / not watched selection icon.

Cfg. Unit The unit of the raw data value used by the system. This column would normally not
be displayed since it is of no use to the Diamond Logic® Builder software user.

Name Displays the signal name.
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ESC Signals Sub-Tab

All signals programmed into the selected VIN will be displayed on this tab.

Figure 80 ESC Signals Sub-Tab
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Custom Signals Sub-Tab
This tab displays all Advanced Logic signals used.
NOTE - This tab is displayed only when a VIN has Advanced Logic applied to it.

When the Reel_Gate_Input_Switch signal is highlighted, the lower portion of the window populates with the
corresponding Advanced Logic for the selected signal.

Figure 81 Custom Sub-Tab
Master List Sub-Tab

The Master List sub-tab displays all signals that could be programmed to a VIN. This tab will also display the
Advanced Logic corresponding to the selected signal.
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Watched Sub-Tab

The Watched Tab shows signals that have been selected to be monitored as a result of clicking the “Make
Session” button, by selecting a saved session or by selecting signals while viewing other tabs.

Figure 82 Interlocked Switch Signal — Switch On

Signals to be watched can also be selected from the master or customer signal list. This is done by highlighting
the desired signal and clicking the eye icon. In the figure above, the Interlocked Switch signal has been
selected. Here, the signal output indicates 5 amps. The figure below, however, shows the same signal with the
Interlocked Switch in the center panel Off. Notice that the signal output is now zero.

Figure 83 Interlocked Switch Signal — Switch Off
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Graph Sub-Tab

While in Diagnostic Mode, the Graph sub-tab allows you to view signals that are being “watched” in a
graphical format.

These graphs can be saved for future review.
NOTE - The graphing feature is seldom used as there are other places, connector views, and signal
views where you can watch signal interaction. Setting, arming and using triggers to start and stop

graphs requires some practice.

To select the signals to be graphed, open the ESC Signals tab and click the eyelid icon for each desired signal.
The icon will change to an open eye for signals that have been selected.

Select only the required signals. Viewing too many signals on a graph will make it difficult to distinguish
between them. If it is necessary to deselect a signal, simply click the open eye icon.

®

Figure 84 Record Icon (Select Trigger)

When selecting the Graph sub-tab, the graph will not be displayed until a trigger is selected and activated or
the Record Button in the toolbar is clicked to arm / disarm the trigger.
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Setting a Trigger

To configure a trigger:

1. In the menu bar, select Diagnostics > Edit Triggers. The Edit Triggers window appears. This is where
the user can select which signal will start the graph in the session

Figure 85 Edit Triggers: Signal Source Dropdown

2. In the Signal Source dropdown (upper left corner of the Edit Triggers window), select the source of the

desired signal. For example, if you want to use a signal that is listed on the Watched sub-tab, select
“Watched.”

Figure 86 Edit Triggers: List of Signals
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In the dropdown immediately to the right of the one modified in the previous step, select the specific
signal to use as a trigger.

NOTE - This dropdown lists all the signals from the specified source. So, if “Watched” had been
selected in the previous step, it would list all of the signals that appear on the Watched sub-tab (in

other words, all signals that the user has chosen to watch).

Figure 87 Set Trigger Conditions — AC_Request ON

Specify when the selected signal will trigger recording of the signals to be graphed.

* Rising Edge: Select this option if graphing should begin when the specified signal goes ON / TRUE.
» Falling Edge: Select this option if graphing should begin when the trigger signal goes OFF / FALSE.

+ Value: If graphing should begin when the trigger signal reaches a specific value, enter the desired
value. Note that this field may be a checkbox, a text entry field or a dropdown menu, depending on
the type of signal selected.

* Faults: If graphing should begin when a certain number of faults have occurred, enter the desired
number of faults.

Specify the number of second that should be recorded after the trigger conditions indicated above are met.

Click OK to close the Edit Triggers window.

$

Figure 88 Record Icon (Signal Trigger)

Click the Record icon to start the recording session.
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Figure 89 Graph Sub-Tab, After Record is Clicked

Once the session is running, your graph will start to move.
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Figure 90 Graph Sub-Tab, Recording Changes
8. To see the graph change and the trigger set, force the trigger signal to the condition specified in Step 4.
For example, if the trigger had been configured as shown in Set Trigger Conditions (Figure 87), you
would set the AC_Request signal to ON.

Once the trigger is set, the recording will automatically stop after the post trigger time has expired.
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Saving Recorded Data

Although it is not recommended, custom sessions can be created and saved for later reference.

Figure 91 Saving a Session

1. In the menu bar, select Diagnostics > Save Session As. The Save Session window appears.

2. Enter an appropriate filename for the saved session. (Session files will be saved with the .dls
filename extension.)

3. Click Save.
NOTE - Be sure to note where your session is being saved to make it easy to find later.

It is also possible to save the graphical data to a .csv file (a file of raw data values, separated by commas).
Such files can be easily imported into spreadsheets and other programs that are used to manipulate and /
or present data.

To save data to a .csv file, select Diagnostics > Save Graph Data in the menu bar.
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CENTER PANEL TAB

The Center Panel Tab allows the user to view the vehicle Switch Panel arrangement. Horizontal and vertical
scroll bars appear when needed for full view.

Figure 92 Center Panel Tab, Example 1
Center panel views will vary depending on the vehicle selected. In the figure above:

»  The four rows of switches on the left each represent a slot in which a switch pack may be installed. The
wire connection shown between the first two rows indicates that the second switch pack is present and
populated.

» The Light Control Module (LCM) appears in the upper right. When the LCM appears on this tab (rather
than the Cluster tab), the two rectangular switches may be dragged and dropped like any of the switches
on the left.

» Up to six auxiliary gauges may appear in the lower right. In this case, there are no auxiliary gauges
installed.
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The figure below shows a different vehicle that has four rows in which switch packs may be installed (two of
which are used), but nothing else on this tab.

Figure 93 Center Panel Tab, Example 2
Viewing Switch Feature Codes

Hovering the mouse over a switch will display the feature code associated with that feature.
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CAMPAIGN TAB

The Campaign tab is used to push programming changes that are set up as Campaigns. A Campaign ID will
only be shown if there is a campaign that applies to this vehicle.

Figure 94 The Campaign Tab
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MESSAGES TAB

The Messages tab allows the user to view configuration errors, warnings and the programming history for
the last programming change.

Figure 95 The Messages Tab
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Upper Panel

The upper panel displays a list of configuration errors (if any).

Figure 96 Messages Tab, Upper Panel

Double-clicking on one of these messages will cause the message to be displayed in a popup window. The
window contains the same text that appears in the Long Message column. However, it may be useful when
that column is turned off or when the message is too long to be fully displayed in the Long Message column.
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Figure 97 Configuration Error Detail
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Types of Errors (What Do They Mean?)

Listed below are some examples of error messages and what causes them:

Feature xxxxxx and Feature xxxxxx conflict — This error is generated when attempting to add two
features that conflict with one another. For example, if the user tries to add 595259 (a feature for normally
closed solenoids) and feature 595297 (a feature for normally open solenoids), this will generate the error
shown below because the two different types of air solenoids cannot be used at the same time.

Figure 98 Feature xxxxxx and Feature xxxxxx Conflict Message

XXXX value required by feature XXXXXX isn’t provided — This error is generated when parameters
that are required by a feature are missing. For example, this error will be generated if the user tries to
add 595179 (ESC / BC Programming for PTO) without adding a feature that would indicate what type of
PTO will be used.

When you add a feature (for example, 595252 — Electric over Air, Non Clutched) that contains the
parameters required by 595179, the error message will clear.

Figure 99 Value Required by Feature XXXXXX Isn’t Provided Message
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Simulation Error — This error will be generated if the user attempts to simulate a program within DLB
that exceeds the ESC / BC’s processing time limit.

This error is displayed as a pop-up on the screen that the user is currently viewing.

In order to eliminate this error, have the dealer or Body Builder reduce the number of rungs used within
Advanced Logic or reduce the number of features applied to the truck.

Figure 100 Simulation Error Message
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Columns in the Upper Half of the Messages Tab

The columns in the upper half of the Messages Tab include the following:

Name Description

Message Displays a particular error. Double-clicking will produce a pop-up window that displays
the long description.

Type Describes the conflict.

Long Message Describes the conflict in detail.

Trace Trace is meant for debugging software errors and is of no use to most Diamond Logic®

Builder users. This column should be left off.

Columns in the Lower Half of the Messages Tab

The lower half of the Messages tab lists changes that have been made to a vehicle configuration since the
last time it was programmed into a vehicle. This list will be cleared once the new configuration has been
programmed into the vehicle and a new “READ” operation has been performed on the vehicle electrical
system controller.
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DETERMINING THE VEHICLE’S CURRENT CONFIGURATION
GETTING VEHICLE CONFIGURATION HISTORY

The computer must be online connected to the Internet to get vehicle information from history.

Figure 101 Get Vehicle Configuration Icon
1. Open the Vehicle Configuration History Requests window by doing one of the following:

* In the toolbar, click the Get Vehicle Configuration Icon.

* In the menu bar, select File > Get From History

Figure 102 Vehicle Configuration History Requests
2. In the VINs box, type the vehicle’s VIN or the 8-digit chassis number.
3. Click the Request VINs button. The VIN requested appears in the list. Depending upon the usage of the

Vehicle History Service by other users, the system will load your requested vehicle configuration file onto
the computer. This will take from a few seconds to a few minutes.
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4.

Figure 103 Confirm Overwrite Window
If the user already has previous copy of the VIN file on the computer, a Confirm Overwrite window

appears. Select Yes to override the current vehicle configuration version on the computer and highlight
the vehicle in the listing.

Figure 104 Vehicle Highlighted in List
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ADDITIONAL BUTTONS IN VEHICLE CONFIGURATION HISTORY REQUESTS

The Vehicle Configuration History Requests window has two additional buttons: Remove Selected Requests
and Work Online.

Figure 105 Vehicle Configuration History Requests Window
Remove Selected Requests
Clicking the Remove Selected Requests button will remove the selected VIN request from the list.
Work Online

Selecting the Work Online button, will allow the user to work online or offline. Working “online” means that the
user is connected to the Diamond Logic® Builder program resources at Navistar through the Internet.

!

Figure 106 Offline Icon (No Signal)
When DLB is being used offline, the icons in the following locations will indicate that there is no signal:

*  Work Online / Work Offline button in Vehicle Configuration History Requests window
» Toolbar Go Online / Go Offline button
*  File Menu Work Online / Work Offline option.
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OTHER WAYS TO OBTAIN VEHICLE INFORMATION
Connecting to the Vehicle

The user can also get the vehicle information by simply connecting up to the vehicle. This is the most
accurate way.

» If the user does not have a version of the vehicle’s information already, connecting to the vehicle will
automatically read the information contained in the ESC / BC.

« If the user has a version but the vehicle is at a later revision, click the Get Data icon in the toolbar to read
the latest configuration from the vehicle.

MGet Datav

Figure 107 Get Data Icon
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CREATING AND APPLYING A TEMPLATE

A template is a separate file that captures and stores vehicle configuration changes that have been performed
using the Diamond Logic ® Builder software. These changes can be any of the following:

* Adding / Deleting 595XXX or 597XXX Features

» Changing Programmable Parameters

*  Moving Pin, Switch or Gauge Locations

+ Adding or Modifying Advanced Logic Blocks

A template is a programming guide that summarizes the features and parameter settings that are to be
applied to a vehicle configuration. The template can be loaded to a vehicle and can be saved for future use

on additional vehicles. Once a template is saved it can be exported or emailed just like any other data file.
Multiple templates can be applied to a vehicle or a series of vehicles.

Extreme caution should be taken when using multiple templates on the same vehicle. The user cannot use the
same resources in two different templates and then program the templates on a vehicle. The overlapping
resources will conflict. If multiple templates are use, the user must ensure that resources are used only once
per vehicle. It is suggested that only one template be used on a vehicle, thereby eliminating the chance of
using resources more than once.

There are two options available for creating a template:

+ Creating a New Template from Scratch

* Modifying a Copy of an Existing Template
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CREATING A NEW TEMPLATE FROM SCRATCH

1. In the Menu Bar, select File > New. The New Template window appears.

Figure 108 New Template Window
2. In the VIN box, enter a name for this template.

3. For each module to be added to the template:

a. In the dropdown to the left of the Add button, select the module to be added. The options for the
selected module will now be listed in the table below the dropdown.

b. Select the desired value for each listed option.

c. Click Add to add the selected module to the list in the upper portion of the window.
4. Once all desired modules have been added to the list, click OK to create the template.

The new template should now be listed on the Select tab.
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CREATING A NEW TEMPLATE FROM AN EXISTING TEMPLATE OR VIN

It is possible to create a template based on an existing template or VIN. This simplifies the creation of a
template if the new template will differ in only a few options or attributes from the already existing template

Figure 109 Select Tab

1. On the Select tab, click the existing template to copy.

2. In the menu bar, select File > Make Template. The Make Template window appears.

Figure 110 Make Template Window
3. Enter a 1 — 16 charter name for the new template.

4. Click OK.

The new template will now be listed on the Select tab.
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Figure 111 New Template Listed on Select Tab

On the Select tab, templates will have a green check in the Template column.

TEMPLATE MAINTENANCE

IMPORTANT - It is extremely important to save and back-up copies of all templates created or changed.
Navistar does not store or retrieve templates. Until the templates are applied to a vehicle and the vehicle
is programmed, they are just templates on your computer. Navistar only tracks vehicle information that
has been programmed into a vehicle.

IMPORTANT - It is highly recommended that the vehicle configuration be printed whenever modifications are
made to a VIN. These modifications include (but are not limited to): adding, deleting, moving, or modifying
switches, features, advanced logic, or outputs / inputs on the connectors.

The printed vehicle configuration should be stored with the vehicle for future reference in diagnostics, repair,
and modification or reprogramming.
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APPLYING A TEMPLATE
Follow these steps to apply a template and program a vehicle:

1. On the Select tab, select the vehicle to be programmed.

Figure 113 Selecting the Vehicle

2. In the toolbar, click the Apply Configuration icon.

™

Figure 114 Apply Configuration Icon

The Apply Templates window appears.

Figure 115 Apply Templates Window

3. Select the template to be applied.

4. Check the boxes of your choice in the Apply section.
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5. Click the Apply Selected Templates button. It is possible to select and apply several templates to a vehicle.

Figure 116 Apply Templates Window, with Template Selected
After applying the template, the selected vehicle displays “Unsaved Changes” in the Status column.

NOTE - It is highly recommended to use the Connectors, Signals, and Features tabs to verify the
accuracy of the pins, switches, and programmable parameter changes the user has made.

6. Save changes to the selected vehicle by doing one of the following:

¢ In the Menu Bar, select File > Save.

« Click the Save icon in the toolbar.

Figure 117 Save Icon

7. Program the changes into the vehicle (See Programming a Vehicle, page 122).
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1.

2.

ADDING A FEATURE

On the Select tab, select the template or VIN or template to which this feature is to be added.

Figure 118 Selecting a Template

Click the Features tab. The upper portion of the tab lists all features that have been developed for the
ESC / BC.

With a VIN selected, the listing is organized in three different columns:

» The Feature column identifies the software identification number for each packet of software code.
These packets are referred to as 595 or 597 codes because the identification number always starts
with either 595 (595XXX) or 597 (597XXX).

* The Description column provides a short text description of the feature.

* The Installed column indicates the installed status of a feature for the vehicle configuration. A checked
box indicates the feature IS installed in the vehicle’s configuration. An Unchecked box indicates that
the feature IS NOT installed in the vehicle’s configuration.

NOTE - A “grayed out” box, with a check mark, means that the feature is active but cannot be
changed with the current user’s permissions.
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Figure 119 Feature List

When a template is selected, you may also want to enable the Added With Template and Removed with
Template columns. To do this, right click on the any of the column headings, and then check the names of
these additional columns in the right-click menu.

With these two active, the listing would have five different columns:

The Feature column identifies the software identification number for each packet of software code.
The Description column provides a short text description of the feature.

The Installed column indicates the installed status of a feature for the vehicle’s configuration. A
checked box indicates the feature IS installed in the vehicle’s configuration. An Unchecked box
indicates that the feature IS NOT installed in the vehicle’s configuration.

The Added with Template column provides the option to include features in VIN configurations when
this template is applied. A checked box means the associated feature will automatically be included
in all VIN configurations that have this template applied to them. An unchecked box has no effect
on the template.

The Removed with Template column provides the option to remove features from VIN configurations
when this template is applied. A checked box means the associated feature will automatically be
removed from a VIN configuration when this template is applied to them.
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The listing of features may be sorted in multiple ways. Clicking on any of the column headings will cause
the entire table to be sorted in an ascending or descending order as defined by the column data.

3. Scroll through the available features until the one to be added is found. Check the Installed box to add
the feature.

Figure 120 Feature List, with Feature Selected

The lower half of the tab now displays a list of programmable parameters that are associated with this
feature. Not all features will have programmable parameters.
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Figure 121 Editing Parameter Values

4. Edit the parameter values in the lower half of the window as needed / desired. To edit an individual value:

a. Select the parameter to edit. An editable field for the selected parameter will now appear in the
lower-left corner of the window. A description of the parameter will be displayed in the lower-right
corner.

b. Edit the Value displayed in the lower-left corner. There are three types of values:
* If the parameter permits an ON or OFF value only, there will be a check box. A checked box

indicates the programmable parameter is on. An unchecked box indicates the programmable
parameter is off.

* For parameters that require numerical values, a box is provided to type in the new data value. An
allowable range of values will typically be displayed to the right of the box.

»  Other parameters provide the ability to make a choice from a list. Only one choice from the list
may be selected for the feature file.

NOTE - A value can also be edited by clicking in the Value column of the programmable
parameters listing itself.
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Figure 122 Set With Template Checkbox

5. When editing the programmable parameters in a template, ensure that the associated box in the “Set With
Template” column is checked for each value that has been modified. If this box is NOT checked, the
updated value will not be applied when the template is applied to a VIN.

NOTE - As long as changes are not saved, it is possible to change back to original feature and

programmable parameter choices by selecting File > Revert in the menu bar. Once the file has been
saved, removing feature or programmable parameter selections must be done manually.

Figure 123 Select Tab Status Column — Unsaved Changes
6. Prior to saving, the Status column on the Select tab will indicate that there are Unsaved Changes to the
modified VIN or template (Figure 123). These changes must be saved before they can be programmed
into a vehicle. There are two ways to save changes:

¢ In the menu bar, select File > Save.

¢ In the toolbar, click the Save icon.

Figure 124 Save Icon

On the Select tab, the Status column for the modified VIN or template should now be clear for the modified
VIN or template. (It will no longer indicate that there are Unsaved Changes.)
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Figure 125 Status Column on Select Tab Clear
7. Program the changes into the vehicle (See Programming a Vehicle, page 122).

NOTE - Always refer to the documentation on the Navistar Body Builder website when adding or
removing features or to diagnose and fix any conflicts that may occur.

NOTE - It is highly recommended that the vehicle configuration be printed whenever modifications
are made to a VIN. These modifications include (but are not limited to): adding, deleting, moving, or
modifying switches, features, advanced logic, or outputs / inputs on the connectors.

The printed vehicle configuration should be stored with the vehicle for future reference in diagnostics, repair,
and modification or reprogramming.
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CHANGING PROGRAMMABLE PARAMETERS

It is possible to edit programmable parameters in either a VIN or a template. Be aware, however, that editing
programmable parameters in a VIN will cause the changed values that have been saved to automatically be
programmed the next time the vehicle is programmed.

It is better to create a template from the original VIN and make the parameter modifications to the template.
The template can be applied to the VIN and then programmed in the vehicle.

1. On the Select tab, select the template or VIN whose parameters you wish to modify.

2. Select the Features tab. The upper portion of this tab lists all available features. The lower half of the tab
lists all the parameters available to change on the selected vehicle or template, including their current
value, units, and the ID.

Figure 126 The Features Tab

3. Scroll through the available features and find the feature whose programmable parameters need to be
changed. Select the feature by clicking on its feature number or its description. The lower half of the tab
now displays a list of programmable parameters that are associated with this feature. Not all features
will have programmable parameters.

112



CHANGING PROGRAMMABLE PARAMETERS

Figure 127 Features Tab, with Feature Selected

4. Edit the parameter values in the lower half of the window as needed / desired. To edit an individual value:

a. Select the parameter to edit. An editable field for the selected parameter will now appear in the
lower-left corner of the window. A description of the parameter will be displayed in the lower-right
corner.

b. Edit the Value displayed in the lower-left corner. There are three types of values:
* If the parameter permits an ON or OFF value only, there will be a check box. A checked box

indicates the programmable parameter is on. An unchecked box indicates the programmable
parameter is off.

*  For parameters that require numerical values, a box is provided to type in the new data value. An
allowable range of values will typically be displayed to the right of the box.

»  Other parameters provide the ability to make a choice from a list. Only one choice from the list
may be selected for the feature file.
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A value can also be edited by clicking in the Value Column of the programmable parameters listing
itself.

Figure 128 Editing the Value Column

5. When editing the programmable parameters in a template, ensure that the associated box in the “Set With
Template” column is checked for each value that has been modified. If this box is NOT checked, the
updated value will not be applied when the template is applied to a VIN.

NOTE - As long as changes are not saved, it is possible to change back to original feature and
programmable parameter choices by selecting File > Revert in the menu bar. Once the file has been
saved, removing feature or programmable parameter selections must be done manually.

6. Prior to saving, the Status column on the Select tab will indicate that there are Unsaved Changes to the
modified VIN or template. These changes must be saved before they can be programmed into a vehicle.
There are two ways to save changes:

¢ In the menu bar, select File > Save.

* In the toolbar, click the Save icon.

Figure 129 Save Icon
7. Program the changes into the vehicle (See Programming a Vehicle, page 122).
NOTE - It is highly recommended that the vehicle configuration be printed whenever modifications
are made to a VIN. These modifications include (but are not limited to): adding, deleting, moving, or

modifying switches, features, advanced logic, or outputs / inputs on the connectors.

The printed vehicle configuration should be stored with the vehicle for future reference in diagnostics, repair,
and modification or reprogramming.
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CHANGING SWITCH, GAUGE AND PIN-OUT CONFIGURATIONS
MOVING CENTER PANEL SWITCHES

Switches on the center panel are generated when programmable features are added to the vehicle on the
Features tab or an advanced logic template when switch features or custom switches are applied.

A switch can be moved by clicking and dragging it to the desired location.

Figure 130 Center Panel Tab
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In the image below, the “MASTER SW” was moved to the lower bank by clicking and dragging.

Figure 131 Master Switch Moved to Lower Bank

Hovering over a switch invokes a pop-up that describes the switch. When hovering over a blank, this pop-up
reads “Plug (No Switch).”
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MOVING SWITCHES ON THE CLUSTER (ON APPLICABLE VEHICLES)

If there are vacant switch locations on the cluster, a switch from the center panel view can be relocated to one
of these locations. To accomplish this:

1. Click on the switch in the Center Panel view.

2. Drag the switch onto the “Cluster” tab and wait for the Cluster tab to open. (Do not drop the switch yet.)
3. Drag the switch onto the Cluster view and drop it onto the desired vacant location.

Switches can also be moved from the cluster to vacant locations in the center panel.

NOTE - DLB will only let you move a switch to a configurable location.

NOTE - Any switch located on the cluster will be activated with the key in the Off position. This provides
a risk of running down the battery if the switch is left On.

Figure 132 Cluster Tab with Two Vacant Switch Locations (Lower Left)
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MOVING GAUGES

The Cluster tab and, on some vehicles, the Center Panel tab allow the user to view the vehicle cluster gauge
and warning light arrangement, as populated by the features enabled in the vehicle configuration. The gauge
positions identified with a blue circle are for optional gauges (which may be moved). All other gauges and
warning lights have a fixed position. Full view of the gauge cluster is accomplished via movement of the
horizontal and vertical scroll bars.

Figure 133 Cluster Tab with Two Vacant Gauge Locations (Left)

NOTE — On some models manufactured in 2017 and later, none of the gauges are moveable.
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To move an optional gauge:
1. Drag and drop the gauge to an empty gauge location (blue circle).
2. Save changes by doing one of the following:

¢ In the menu bar, select File > Save.

¢ In the toolbar, click the Save icon.

Figure 134 Save Icon

3. Program the changes into the vehicle (See Programming a Vehicle, page 122).
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MOVING SIGNALS TO DIFFERENT CONNECTOR PIN LOCATIONS

There is some latitude to relocate signals to different connector locations on the BC / ESC and the Remote
Power Modules. This capability is limited to relocations that are configurable and are permitted by your
DLB programming level.

DLB will generate an error message if you try to move something where is not permitted.

To move a signal:

1. Drag and drop the desired signal from its current location to a vacant location.

2. Save changes by doing one of the following:

¢ In the menu bar, select File > Save.

¢ In the toolbar, click the Save icon.

Figure 135 Save Icon
3. Program the changes into the vehicle (See Programming a Vehicle, page 122).
Errors

If you do not have sufficient permissions to make the change, the following error will be displayed.

Figure 136 Pin Mapping Error
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If you try to change pin assignments on a template, the following message appears.

Figure 137 Template Pin Assignment Warning

Additionally, new messages that advise why the move is generating an error may appear on the Messages Tab.

Figure 138 Error-related Messages on Messages Tab

Use Default

The Use Default option in the Edit Menu will return connector pin mapping, parameter values or switch and
gauge locations to the default settings. This can be helpful when configuration conflicts occur. Use this carefully
and be sure to compare anything that might have changed in the DLB interface to your desired configuration.

NOTE - Using the Default Pin Mapping function may undo any custom pin locations.

NOTE - Using the Default All option may help to clear an error message that shows up in the Messages
tab. Use caution to ensure that any undesired changes were not made.
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PROGRAMMING A VEHICLE
OVERVIEW

The vehicle program is made up of the following discrete software components:

+ Base Kernel Program
»  Configuration Program, consisting of Features and Logic Blocks

* Programmable Parameter file

If the kernel program on the vehicle already contains the latest version available from Navistar, only the
configuration file and programmable parameters would be loaded into the vehicle.

Only VIN files may be programmed into a vehicle. Templates must be applied to a VIN file, saved, and then the
updated VIN file may be programmed into the vehicle.

NOTE - Prior to attempting to program the ESC / BC, ensure that the battery is charged to a least 13
volts, the key is OFF, and the dome light or park lights are on.

1. Connect the vehicle to the computer using an interface cable.

€0

Figure 139 Computer Link Icon
2. Click the Computer Link icon in the toolbar.

3. Verify that the connection is established by checking the icon in the lower-right corner of the window. This
icon should show that the vehicle is connected.

-

Figure 140 Computer Link Connected

NOTE - If you are programming a replacement ESC / BC, a message will appear warning that the
ESC / BC serial number of the Selected ESC / BC and the Detected ESC / BC do not match.

4. Click OK to allow DLB to change the serial number on the selected VIN. This will marry the new ESC / BC
serial number to the ESC / BC and update the VIN database in the Navistar system.

i Programv

Figure 141 Program Icon

5. Click the Program icon in the toolbar.
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Figure 142 Programming Status

The system will load the VIN configuration file into the vehicle. The status bar will display the slider bar
showing programming status.

NOTE - Do not interrupt while the program is loading.

6. Once all required sections of the VIN configuration files are loaded, the status bar will indicate that the
system is resetting. The vehicle is now programmed.

Figure 143 Status Column Empty
Notice that the Status column is now empty for the programmed vehicle.

After a vehicle has been programmed, the user must connect to the Internet and launch the Diamond Logic®
Builder software. Connecting to the Internet will allow the Diamond Logic® Builder program to save the revised
VIN configuration file in the archive at Navistar. For this reason, Navistar suggests making a connection to
the Internet at least once a day if the user has programmed a vehicle.

NOTE - It is highly recommended that you print the vehicle configuration whenever modifications are
made. These modifications include (but are not limited to): adding, deleting, moving, or modifying
switches, features, advanced logic, or outputs / inputs on the connectors.

The printed vehicle configuration should be stored with the vehicle for future reference in diagnostics, repair,
and modification or reprogramming.
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CLUSTER ODOMETER PROGRAMMING

DLB can be used to set the Odometer Value in the LCD display.

1. In the menu bar, select Tools > Set Odometer.

Figure 144 Tools Menu

The Set Odometer window appears.

Figure 145 Set Odometer Window

2. Read and follow the instructions in the Set Odometer window. Then, select the appropriate option for
setting the odometer.
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MODULE UPDATING

The Diamond Logic® Builder software can be used to update other modules that are detected on the truck
data links.

1. In the lower section of the Select tab, select the Detected Modules sub-tab.

2. Right click on one of the Detected Modules to see the dropdown menu shown below.

Figure 146 Detected Modules Right Click Menu
3. Select the desired option. Any module that is not grayed out can be selected.

* The Update Module option updates the module’s software to the latest version.

*  The Program Module option programs any updates made in DLB into the module.
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Figure 147 Edit Menu, Update Software Options
There are also two options in the menu bar that allow users to update module software:

» Select Edit > Update Software > Update All Software to update all modules that are capable of being
updated.

»  Select Edit > Update Software > Update Module to update only the module that is shown as selected in
the Detected Modules sub-tab.
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DIAGNOSING ELECTRICAL PROBLEMS WITH DIAMOND LOGIC®
BUILDER

The Diamond Logic® Builder software can be used to aid in diagnosing and troubleshooting electrical / electronic
system problems. Before proceeding with diagnosing and troubleshooting, there are several important steps:

Verify the Problem — Operate the complete system and list all symptoms. Is the complaint due to
misunderstood, customer-selected, programmed parameters?

Gather Information — What happened and when? Under what conditions? When did the symptoms
begin? What else occurred at the time?

Check Diagnostic Trouble Codes — Do the logged codes correlate to the symptoms and probable causes?
Were the codes logged repeatedly?

Perform Preliminary Checks — Perform a thorough visual inspection. Are any wires loose or corroded?
Are there damaged connectors or pins? Are all components installed and installed correctly? Check to
make sure the vehicle batteries are at 75% state of charge or higher. Make sure indicator lights are
not simply burned out.

Check References — Check all relevant service information including circuit diagrams and diagnostic charts.

ENTERING DIAGNOSTIC MODE

When diagnosing a vehicle using the Diamond Logic® Builder software, the first step is to connect the
system to the vehicle:

1.

2.

Figure 148 Select Tab

On the Select tab, select the vehicle to be diagnosed.

4D

Figure 149 Computer Link Icon

In the toolbar, click the Computer Link icon.
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3. Verify that the connection is established by checking the icon in the lower-right corner of the window. This
icon should show that the vehicle is connected.

-

Figure 150 Computer Link Icon, Connected

4. In the toolbar, click the Diagnostic Mode icon.

Figure 151 Diagnostic Mode Icon

When Diagnostic Mode is ON, the icon appears indented in the toolbar.

Figure 152 Diagnostic Mode Icon, ON
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USING THE SIGNALS TAB TO DIAGNOSE ISSUES

When the Diagnostic Mode is started, an extra data column is added to the Signals tab and the Advanced
Logic tab. This column is labeled LOCK. The WATCH and LOCK columns are essential in performing
diagnostic troubleshooting. The WATCH Column appears as a closed eyelid. Single clicking on the closed
eyelid changes it to an open eye. This enables the signal for diagnosis in real time. The value of the signal
may be viewed in the VALUE column.

If any of these columns are not visible:

1. Right click on any of the column headings. This produces a menu that lists all the columns that
may be displayed in the table.

2. Ensure that the Custom Signal, Signal, Pins, Value, Unit, Status, Watch, and Lock columns are
turned on (checked) as a minimum. If desired, other columns may be checked as well.

Figure 153 Signals Tab with Columns Appropriate for Diagnostics
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Using “Make Session” to Select WATCHED Signals

Clicking Make Session on the Features tab will open a Signals tab session that displays the signals related
to the selected feature.

1. Select the Features tab.

Figure 154 Features Tab

2. Select (click) the feature whose signals you want to watch.

3. Click Make Session to open the Signals tab with the Watched sub-tab selected. The signals that apply
to the selected feature will be listed.
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Figure 155 Watched Sub-Tab

4. If desired, add additional signals by doing the following:
a. Select the ESC Signals sub-tab.

b. Click the eye icon for each additional signal you want to watch.
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Using Signal Status while Diagnosing

Each signal in the Diamond Logic® electrical system has an associated STATUS or health. A STATUS value of
zero indicates a good signal status. Any other value for status indicates that the signal health is bad and will
not be used by the program logic. When troubleshooting, it is essential that the user inspect the STATUS of
system signals being tested to ensure that they have a value of zero. If any of the values are greater than
zero, then go to the Faults tab and look for diagnostic trouble codes.

NOTE - Many signals that have bad status, such as the HVAC thermistors, no longer have related fault
codes.

To quickly find signals that the user wishes to watch:

1. On the Signals tab or the My Variable panel of the Advanced Logic tab, click the Filter button on the
left end of the table heading.

Figure 156 Find Window
2. Enter the word or words to search for.
3. Click OK.
By observing the data in the VALUE column, the user can monitor the value of selected signals. ON / OFF

signals are represented by a check box where the signal is ON when the box is checked. Also observe the
UNIT column to see the unit of measure associated with the signal value.

Figure 157 Observe the Value and Unit Columns
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Forcing Signal Values

In addition to monitoring signal values, the user can also force signals to a predetermined value. For example,
the ACCESSORY signal can be forced ON or OFF just by checking or unchecking the box in the value column
on the ACCESSORY line. The accessory voltage is not actually being forced ON or OFF, but from an ESC

/ BC programming logic standpoint it is. Therefore, all the features or Advanced Ladder Logic that use the
ACCESSORY signal will respond according to the ON / OFF state of ACCESSORY.

Once a signal is forced to a new value, the LOCK icon in the lock column will show as locked. When locked,
changes by external inputs such as switches or sensors will be ignored.

To restore the signal to an unlocked condition, click on the LOCK icon; now the signal will respond to normal
system inputs and outputs. Alternately, unlock all locks by taking the DLB software out of Diagnostic Mode.
You will have to return to Diagnostic Mode to continue diagnosing.
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Signals and Custom Logic

It is also possible to examine Custom Signals and Ladder Logic on the Signals tab. An example is shown in
the figure below.

Figure 158 Custom Values and Ladder Logic
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In the first Ladder Logic rung, there is SW_1 and a Park_brake; SW_1 is off as indicated in the grayed area. In
the signal listing, clicking the SW_1 Value check box turns on the switch.

Figure 159 SW_1 Switch is ON
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USING THE CONNECTORS TAB TO DIAGNOSE ISSUES

Signal values that are present on physical pins of various electrical modules can be observed by selecting the
Connectors tab. Note that there is a tab for each module. Use the connector view to help isolate the problem.
The connector views provide the ability to monitor system values without the use of breakout boxes. Scaled
voltages, temperatures, and pressures are presented for analog voltages and checkboxes are provided for
ON / OFF values.

Figure 160 Connectors Tab

On the Connectors tab, you can observe the state of each input and output from the ESC / BC and each RPM
and MSVA. You can also override each input and output.
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To view individual inputs and outputs:

1. Select the sub-tab for the module that you wish to view. The sub-tab displays an image of the
module and its connectors on the left.

2. Select a connector in the image on the left by clicking on it. The selected connector becomes
shaded in gray and is displayed on the right.

Figure 161 Selected Connector Displayed on Right
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RPM Output Connector View

The figure below shows the output connector for RPM 1. To select an output, click on its name. The selected
name and the corresponding pin in the connector drawing will appear highlighted in yellow. Selecting an
output in this way will also automatically select this output in the Signals tab. This is very helpful if you are
not sure of the feature code that controls a particular RPM output. To turn off the yellow highlight, hold down
the Ctrl key while selecting an output.

Figure 162 RPM Output Connector View, Outputs on Right (Typical)

Several pieces of information are displayed for each output: (Refer to figure above for numbered items.)

Item | Description

1 Cavity pin numbers (shown in brackets)

2 Entering a voltage here sets the value of this output to the entered value.

3 The lock icon is used to lock and unlock the output to the value entered to the left (Item 2). When
locked, no other signal can drive that output. (When unlocked, a blank space appears here. Click
the blank space to lock the output.)

NOTE - If you are having trouble with outputs not turning ON or OFF as expected, check to
make sure those outputs are unlocked.

4 The current level (in Amps) that this output must reach in order to trigger the virtual fuse configured
for this output. The default is 20.

5 The name assigned by the feature that is using this output.

NOTE — A bold output name would indicate that a custom name has been assigned to this
signal by advanced logic.
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Information about the outputs on the left of the connector are displayed in roughly the opposite order.

Figure 163 RPM Output Connector View, Outputs on Left (Typical)
RPM Input Connector View

Input connectors, like the example shown below, are represented in a similar manner as output connectors,
with some minor differences.

Figure 164 RPM Input Connector View (Typical)

Each pin of an input connector can be programmed in the ESC / BC to respond to either a 12V signal or
a ground signal.

The lock works the same as it does on the output connector.

The input connector will also show the addressing; note the jumper wire between pins 1 and 2. Jumper wires
on the input connector determine how an RPM is addressed. Addressing is extremely important. RPM
input connectors should not be moved around. Doing so will move all inputs and outputs programmed

to that particular RPM.
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DIAGNOSTICS ON THE ADVANCED LOGIC TAB

Diagnostics Sub-Tab

The Diagnostics sub-tab allows the Advanced Logic writer to provide information regarding the advanced
logic. If such documentation has been provided on this sub-tab, it may contain valuable information for
diagnosing the advanced logic.

Ladder Logic Sub-Tab

Diagnostics in the ladder view are simple and straightforward:

1. Connect to the truck.

2. Enter Diagnostics Mode.

3. Select the Advanced Logic tab. On this tab, gray OFF or brown question mark shadow blocks will be seen
over most items. Brown shadow blocks indicate items that the present state cannot be determined. On the
right of the window, you will see the tabs that contain all the signals that can be used in advanced logic.

4. At this point, you can observe actual signals received from the truck.

For example: while hooked up to the vehicle, in Diagnostic Mode and on the Advanced tab, you can observe

the actions on the vehicle. The figure below (Figure 165) shows an advanced block with a switch in the first

rung of the ladder logic. There are two ways of testing to ensure the vehicle is working properly. The first is to
actually activate the switch in the vehicle and watch for the outcome on the screen. The second is to override
the switch and click the checkbox in the value column on the right of the screen. Clicking the checkbox is the

way to test out the advanced logic in the simulate mode. This tells the ESC / BC to ignore the switch state
and activate the circuit regardless of switch location

Figure 165 Advanced Logic Block with a Switch in the First Rung
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The next figure shows the same view with the switch in the up position. Notice on the left side of the window,
the graphic display shows that the switch and corresponding outputs are now in the ON position. The right side
of the screen now has checkmarks in the items that have been set to ON. Returning the switch to the OFF
position will once again turn OFF the switch and the switch outputs.

Figure 166 Switch in First Run is Now ON

Each of these techniques has value. For items such as switches and the park brake, it is very easy to either
turn them ON or OFF. However, for items such as intermediate variables created in the ladder logic and RPM
input signals, the value column is an excellent option. This overrides the vehicle signal. By observing the
reaction of the logic rung, you can diagnose the vehicle. If all the items on the left side of the logic block are
properly set, the value on the right should be either ON or OFF. If the contact, light, or output indicator is on in
the Diagnostics tab, then the output should also be on; if not, check for a fault code in the Faults tab.
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DIAGNOSTICS ON THE CENTER PANEL TAB

In Diagnostics Mode, the Center Panel tab displays images of the switches. A yellow line represents the
multiplex data link tying the switch packs together. Arrows indicate the current switch setting of each switch.
When the state of the actual switch is changed, the arrows and images will change and indicate the new state.
Diamond Logic® Builder can override switches.

When Diamond Logic® Builder is used to cycle switches, the arrows and images will change, indicating the new
state. Additionally, the padlock icon will appear, indicating a locked condition.

Figure 167 Center Panel Tab
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To override a switch, either left-click on the desired switch setting or right-click on the switch and select a
desired setting from the right-click menu.

Figure 168 Switch Right-Click Menu

Clicking the top portion of the switch will activate that switch output and the arrow will move to the up position.
This overrides the switch and allows you to determine if there is a switch problem.

Figure 169 Switch in ON Position, with Lock

The padlock, which appears on a switch, allows you to lock that signal in any of the switch’s valid positions.
Click on the lock to remove it.

When diagnosing switches, it is important to remember a few facts:

The switch rocker is nothing more than a pair of plungers. When a switch is pushed, it pushes one of
the two plungers in and contacts a micro switch in the switch pack.

Each switch location has two micro switches. The switch can be in 1 of 3 valid states; micro switch 1 is
depressed, micro switch 2 is depressed, or neither micro switch is depressed.

When diagnosing a switch by checking the box in the Signals tab, the Features tab, or the Advanced
Logic tab (while in either Diagnostic Mode or Simulate Mode), you must select the switch position you
want, such as the switch up position. You must also make sure that the switch middle and switch down
boxes are not checked. If you have more than one switch state selected in the Advanced Logic tab or
the Signals tab, your switch will show yellow in the Center Panel tab. This tells you that you have put
the switch in an illegal state.

Turn OFF or unlock the individual switch signals in the Signals tab before you continue with diagnostics or
simulation with the Center Panel tab.
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DIAGNOSTICS IN THE CLUSTER TAB

When the Cluster tab is selected in Diagnostic Mode, the movement of the gauges mirrors the movements
of the actual gauges. For example, if the fuel gauge does not appear to be working, you can check the
gauge cluster view and see if the signal is driving the Diagnostic Mode gauge. If the gauge in the is working
in Diagnostic Mode, but the actual gauge is not, follow the Navistar troubleshooting guide to complete the
diagnosis.

By placing the cursor on the outer ring of a gauge and clicking the left mouse button, the user can override the
actual gauge signal. This forces the gauge to the reading indicated by the cursor location. In the illustration
below, the tachometer has been clicked at the 1300 RPM mark.

Figure 170 Cluster Tab

When observing the gauges in Diagnostic Mode, a gauge may momentarily dip to 0. This occurs because of
the high update rate required by some gauges and an update may occasionally be missed. The speedometer
and the tachometer are most susceptible to this anomaly because of their high update requirements. This is a
normal condition and is not an indication of a defective gauge.
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Double-clicking in an area around the center of a gauge will bring up a text box in which a specific gauge set
value can be entered. The gauge should follow the diagnostic gauge setting. If the gauge does not follow
the diagnostic gauge, then follow the Navistar troubleshooting guide.

Figure 171 Temperature Gauge Double-Click Box
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DIAGNOSING AND CLEARING FAULT CODES

When DLB is in Diagnostic Mode, it will display fault codes generated by most modules communicating

on the J1939 (CAN) Data Link.

Figure 172 Diagnostic Mode Icon

To enter Diagnostic Mode, click the Diagnostic Mode icon in the toolbar.

Erasing Faults

Figure 173 Clear Faults Icon
To erase faults:

1. Click the Clear Faults icon in the toolbar. A window like the one shown below will appear.

Figure 174 Select Modules Window
2. Check the box next to each module that you wish to clear faults from.
3. Click OK to clear the faults from the selected modules.

If fault codes are still active, they will repopulate the Faults tab.
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Decoding Diagnostic Fault Codes

The user can decode diagnostic fault codes directly by selecting the Faults tab.

Figure 175 The Faults Tab

The Faults tab provides a very comprehensive description of a diagnostic fault for the Body Controller / ESC
including text description, probable cause, connector pin associated with the fault, and the module associated
with the fault. Note these faults are only associated with modules communicating on the J1939 (CAN) Data link.

Tips

Diagnostic fault codes will only be viewable on the Faults tab while the ignition key is in the run position.
The engine does not need to be running to view the ESC / BC codes.

Diagnostic programs provided by the power train component suppliers can still be used to diagnose
those systems.

For all vehicles, the Diamond Logic® Builder program will show fault codes from the Body Controller. For
more recent vehicle models, DLB may also show fault codes from the instrument cluster, from the door
pod, and from the LCM. Diagnostic programs provided by the power train component suppliers can still
be used to diagnose those systems.

When diagnosing the gauge cluster with the Diamond Logic® Builder program, the pointers may not be
stable. The pointers may be steered to 0 intermittently. This is normal. Do not replace the gauge cluster
due to this anomaly. It is important that the user can steer the gauge to a nominal value and that that
the pointer does not stick or jump in the process.
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Module Detection

The Diamond Logic® Builder program has a module detection function. The purpose of this function is to
provide a quick look at which electrical system modules are communicating on a data link or should be
communicating on a data link. Selecting the Detected Modules sub-tab will display the modules that are
communicating on the Drivetrain J1939 Data Link. Selecting the Inferred Modules sub-tab will display all
modules that are expected to be present in the configuration of the vehicle but are not communicating.

Figure 176 Inferred Modules

Modules that do not communicate on the Power Train J1939 Data Link (but do communicate on one of the
other data links) will have a blank in the detected column. Currently the system accurately detects modules
that are connected to the power train J1939 Data Link.

Modules that are not, but should be, communicating on the Power Train J1939 Data Link will have an X icon in
the detected column. See the Inferred Modules figure above (Figure 176).

NOTE - The Sniffer function in ServiceMaxx™ is better than DLB for identifying items talking on the data
link.
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USING SESSIONS AND TRIGGERS

The session function allows a user to save a custom group of signal selections to an electronic file, which can
be used in the future. This allows the user to quickly select a set of signals to use during diagnostics. Sessions
can only be used in Diagnostic Mode. Selected signals and trigger settings are also saved in the session.
NOTE - Creating and saving sessions is not recommended. Clicking Make Session while viewing the

Features tab will open a signal session displaying the signals related to that feature. This should meet
most of your Signal Session requirements.

OPENING A SESSION
If you have previously saved any sessions, you can reopen them. To open a session:

1. In the menu bar, select Diagnostics > Open Session.

Figure 177 Opening a Session
A window that prompts the user for the location and filename of the desired session appears.
2. Select the session file to be loaded.
After a session has been loaded, the session’s signals can be viewed on the Signals tab. Select the ESC

Signals sub-tab to view all signals in the vehicle configuration that are present in Navistar®-designed features
on the vehicle. Select the Watched sub-tab to see a listing of signals used in the selected session.
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CREATING A SESSION

Creating and saving sessions is not recommended. It is better for most users to click the Make Session button
on the Features tab. This opens a signal session that displays the signals related to the selected feature.
Refer to Using Make Session to Select Watched Signals (See Using “Make Session” to Select WATCHED
Signals, page 130).This should meet most of your session requirements. The following information is provided
for advanced users who might need to use the Graphing and Trigger functionality in DLB.

To create a session:

1. In the menu bar, select Diagnostics > New Session.

Figure 178 Creating a New Session
2. Select the Signals tab.
3. Select the sub-tab that lists the signals to be watched:

* The ESC Signals sub-tab lists all signals in the vehicle configuration that are present in
Navistar®-designed features on the vehicle.
+ The Custom sub-tab lists all ladder logic signals that have been created in Advanced Logic.
* The Master List sub-tab lists all possible signals in the Diamond Logic® electrical system. Note that the
vehicle being diagnosed will only have a small subset of the Master List of signals.
4. In the chosen sub-tab, use the search utility to find the signals to graph or record.

5. Enable each signal to be watched by clicking the eyelid icon next to the desired signal. When the eyelid
changes to an open eye, the signal is selected.
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6. Select the Watched sub-tab to see the list of all selected signals. Verify that all desired signals are
listed. In the figure below, BC_RCD_Tempt_In_Raw_Signal, BC_RCD_Temp_Out_Raw_Signal, and
Switched_5V_Sense_Raw_Signal have been selected.

Figure 179 Selected Signals on the Watched Sub-Tab

7. In the menu bar, select Diagnostics > Save Session. The Save Session window appears.

Figure 180 The Save Session Window

8. Navigate to the folder in which this session should be saved and enter a filename for this session. The
example above uses the name 3h365533.

9. Click Save.
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The signals chosen to watch can be retrieved as a session file with the name entered. All session files are
given the .dIs file name extension. For example, the full name of the file whose name is being entered in
the figure above will be 3h365533.dIs.

In addition, this file can be sent by email.
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SELECTING SIGNALS FOR RECORDING AND GRAPHING

In this example, we will watch two switches set up in custom logic and the associated indicators for the switches.

1. Select the Signals tab and then the ESC Signals sub-tab.

Figure 181 ESC Signals Sub-Tab

2. Click the Custom Signal heading to move custom signals to the top of the list.

e’

Figure 182 Not Watched Icon

3. Select each signal to be watched by clicking the Not Watched icon for each desired signal.
o

Figure 183 Watched Icon

The icons will change to indicate that the corresponding signals are now Watched.

Figure 184 Watched Sub-Tab
4. Select the Watched sub-tab. Verify that the desired signals are now listed here.

5. Select the Graph sub-tab.
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®

Figure 185 Recorder Icon
6. Click the Recorder icon in the toolbar.

NOTE - The Recorder icon can be selected only while DLB is in Diagnostic Mode. Therefore,
graphing can be performed only while DLB is in this mode.

Figure 186 Diagnostic Mode Icon
7. Click the Diagnostic Mode icon in the toolbar to enter Diagnostic Mode.

NOTE - DLB will not switch to Diagnostic Mode unless it is connected to a vehicle and
communicating with the ESC / BC.
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The graph below shows the results of turning ON Switch 1 and Switch 2 then turning OFF Switch 2 and
Switch 1.

Figure 187 Graph Showing Switches Being Turned ON and OFF

The Recorder icon in the toolbar both starts and stops the recording of data to the graph. Additionally, it arms
the triggers. If no triggers have been set, recording to the graph continues until the user stops it by clicking the
Recorder icon again. If there are triggers set, the user can still manually stop the recording by clicking this icon.

Recording and Graphing Views

The Graph sub-tab shows data formatted in specific scaled data views, such as volts, pressure, or digital ON /
OFF signals shown as a 1 or a 0. The graphing area is divided into as many views as are required to display
all the data types. Therefore, it is desirable to keep the number of signal types watched to three or less.

All signals of a given data type will be displayed on the same graph. Therefore, the user should minimize

the number of signals that are watched on any single graph. The graphical recorder is able to record a
single new data point every 50 milliseconds (0.050 seconds). Therefore, it is important to minimize the total
number of signals watched to less than 10 to maintain a close representation of the real time graphing of the
signals. Watching more than 10 signals will result in possible missed signal transitions on the graph, plus

the graph will be hard to read.
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USING SESSIONS AND TRIGGERS

USING THE TRIGGER FUNCTION

Triggers are used to detect a condition and mark it on the graph. Triggers can also stop the recording on the
graph after a specified amount of time so the trigger condition does not get lost. If you kept recording forever
the trigger would be lost 10 minutes after it fires because DLB will only keep a maximum of 10 minutes of
data. The recorder must be started to begin the trigger process. The system will begin recording even though
the trigger event may not have occurred yet. When the trigger does occur, the graph will be marked with a
start line. The recording will continue until the selected amount of time has elapsed, the graph is stopped
manually, or the maximum recording time has expired.

Setting Up a Trigger

In the menu bar, select Diagnostics > Edit Triggers. The Edit Triggers window appears.

Figure 188 The Edit Triggers Window

The dropdown menu in the upper-left of this window allows you to choose the category of signal to view.
Once a category is selected, use the dropdown menu in the upper-right to choose the individual signal to
use as a trigger. The trigger can be set up to detect when the signal goes active (Rising Edge), when the
signal goes inactive (Falling Edge), or when it reaches a specific value. The trigger may be delayed until the
occurrence (Fault) has occurred after a specified number of counts. Finally, the trigger may be set to stop
recording after a specified time.
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USING SESSIONS AND TRIGGERS

Figure 189 Trigger Example

Once a signal is selected, the trigger may be set to fire when a specified value has been detected. The
example above shows that a trigger has been set to fire when the Door_Switch signal turns ON. The trigger will
stop recording 30 seconds after the trigger event occurs.

Saving and Viewing the Graph

The graphed data can be saved in a file that can be read with Microsoft Excel or reopened in DLB for future
reference. To save the graph data:

1. In the menu bar, select Diagnostics > Save Graph Data. A window will open prompting you to name
the file and select a location for saving the file.
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USING SESSIONS AND TRIGGERS

Figure 190 Saving Graph Data

2. In the File name box, enter a name for the saved data file. (Graph data is saved as a .csv file, which is a
plain text file containing comma separated values.)

3. Click Save.

A saved graph file can be reopened with DLB by selecting Diagnostics > Open Graph Data... in the menu
bar. A window will open prompting you to select the file to be viewed.
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CLOSING THE DIAMOND LOGIC® BUILDER PROGRAM

CLOSING THE DIAMOND LOGIC® BUILDER PROGRAM

Follow these steps to close the Diamond Logic® Builder program:

1. If connected to a vehicle, disconnect the link by clicking the Communications Link icon in the toolbar.

-

Figure 191 Communications Link lcon — Connected

The image for this icon on the toolbar should now show a disconnected state. A similar icon will appear in
the lower right corner of the window.

4D

Figure 192 Communications Link lcon — Disconnected
2. Close the DLB program window. There are two ways to do this:

*  Click the Close button (X) in the upper-right corner of the window.

¢ In the menu bar, select File > Close.

Either option will end the session.
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UNINSTALLING THE DIAMOND LOGIC® BUILDER SOFTWARE

UNINSTALLING THE DIAMOND LOGIC® BUILDER SOFTWARE

Follow these steps to remove the DLB software from a computer:

1. If the product key used for DLB on this computer will be used to install DLB on another computer,
unregister this computer by selecting Help > Registration > Unregister this Machine in the menu bar.
This releases the key for use on another computer.

2. In the Windows Start Menu, select All Programs > Diamond Logic Builder > Uninstall.

Figure 194 DLB Uninstall in Windows Start Menu

If Uninstall does not appear in the Start Menu, use the Add or Remove Programs option in the Windows
operating system to remove Diamond Logic® Builder.
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DLB SUPPORT FOR CF 500, CF 600 AND CITYSTAR TRUCKS

DLB SUPPORT FOR CF 500, CF 600 AND CITYSTAR TRUCKS

DLB can be used to set the Odometer Value within the cluster and can drive the J1939 driven gauges
(Speedometer, Tachometer, and Coolant Temperature Gauge). It cannot turn on warning lights or indicators,
nor can it exercise the fuel gauge.

Connect the interface cable to the diagnostic connector. A connection status bar should start to scroll across
the bottom of the DLB display.

Figure 195 Select Tab (Lower Portion)

After the vehicle information has been downloaded, select LCF in the list to display LCF information on
the lower right portion of the Select tab.
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DLB SUPPORT FOR CF 500, CF 600 AND CITYSTAR TRUCKS

TESTING GAUGES

To test the gauges:

1. Click the Diagnostic Mode icon.

Figure 196 Diagnostic Mode Icon

2. Select the LCF Instrument Panel tab. The LCF cluster will be displayed.

Figure 197 LCF Instrument Panel Tab

3. Gauges with red dial indicators can be tested by clicking and dragging the indicator.
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DLB SUPPORT FOR THE VEHICLE INFORMATION DISPLAY (VID)

DLB SUPPORT FOR THE VEHICLE INFORMATION DISPLAY (VID)

The DLB software must be used to program parameters that are not available on the VID on-screen menus.
Other parameters can also be configured with DLB.

Module Selection

Connect DLB to the vehicle as you normally would. Driver Display should be listed in the Module field under
the Detected Modules tab.

NOTE - You may need to pull fuses to prevent other components from communicating on the data link
so DLB will connect to the VID successfully.

On the Select tab, select the Driver Display serial number under Detected Modules.

Figure 198 Select Tab with Driver Display Serial Number Selected
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DLB SUPPORT FOR THE VEHICLE INFORMATION DISPLAY (VID)

Features

The Driver Display tab can be viewed only when a Driver Display or a VID Template is selected.

Figure 199 Driver Display Sub-Tab
Programming

Select the parameter and change it as desired. Use the Program Module option to program the VID only.
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DOS AND DON’'TS

Do

DOS AND DON’TS

Test all designs thoroughly before selling equipment controlled by Diamond Logic® Builder programming.
Exercise inputs and outputs under ALL possible combinations and conditions. Someone in addition to the
advanced logic writer should test the design on the vehicle with the equipment that is to be controlled with
the Diamond Logic® Builder software.

Don’t

Do not try to program a vehicle with the ignition key on. There is too much data traffic on the J1939 Data
Link and the process will most likely fail with a time-out error. Turn the key off and ensure the dome lights or
park lights are on and the battery voltage is between 12.5 and 14 volts. Connect to a charger if necessary.

Information

The user ID is attached to each VIN configuration file when the user programs a vehicle. Adding / deleting
features or changing programmable parameters is the user’s responsibility. Navistar, Inc. shall not be
liable for any consequential warranty or equipment damage resulting from the users programming efforts.

Diagnostic fault codes will be viewable on the Faults tab only while the ignition key is in the Run position.
The engine does not need to be running to view the ESC / BC codes.

Diamond Logic® Builder will show fault codes from most modules communicating on the J1939 (CAN)
Data Link. Diagnostic programs provided by the power train component suppliers can still be used to
diagnose their systems.

When diagnosing the gauge cluster with Diamond Logic® Builder, the pointers may not be stable. The
pointers may be steered to zero intermittently. This is normal. Do not replace the gauge cluster due to
this anomaly. It is important that the user can steer the gauge to a nominal value and that the pointer
does not stick or jump in the process.
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ACRONYMS

ACRONYMS

ABS — Anti-lock brake system

AMP — Ampere

ATC — Automatic Traction Control

BC — Body Controller (Replaces ESC in most 2007and newer trucks)
BOC — Back of Cab

DLB — Diamond Logic® Builder

EGC - Electronic Gauge Cluster

ESC - Electronic System Controller

FET — Field Effect Transistor

FR — Front
GA — Gauge
GND - Ground

HVAC — Heating, Ventilation and Air Conditioning

HYD — Hydraulic

I/O — Input / Output

IGN — Ignition

MSVA — Modular Solenoid Valve Assembly (also known as RATM in other areas)

OnCommand™ Service Information— Trademark for Navistar’s website that provides service and diagnostics
information.

PDC - Power Distribution Center
RAM — Random Access Memory
RASM — Remote Air Solenoid Module
ROF - Rear of Frame

RPM — Remote Power Module

RR — Rear

SW — Switch
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ACRONYMS

VIN — Vehicle Identification Number

VSS - Vehicle Speed Sensor
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CONTACT INFORMATION

CONTACT INFORMATION

Navistar, Inc. maintains a customer service technical support line for assistance with Advanced Logic and
programming issues. Please use the following number to contact the Navistar Product Support Center:

1-800-336-4500 option 3 then option 6
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